Web proxy stopped

Hi all,

After an update and a reboot, or IPFire started since a few days, Web proxy service has stopped, which disrupts Internet browsing for my users.

The problem is still present for several months and update, until the core update 162 testing.

Note : When i disabled clamav / Squidclamav, it seems to help keep web proxy service in enabled mode.

Are you having the same issue ?

Best, Stéphane


not running SquidClamAV for several years anymore, I have not observed this behaviour, and do not recall any particular proxy outages before, but the information degree this memory provides is poor. :slight_smile:

Are there any log messages corresponding with Squid stopping? If not, could you please enable debug logging for ClamAV (Squid’s debug log is pretty noisy) and report back if there is anything suspicious in it?

Thanks, and best regards,
Peter Müller


I reported this exact bug to bugzilla.
I’am not using squidclamav.

Bug 12715 - Web proxy not working after reboot


Nope. I run 4 maschines, all with clamav + squidclamav and non-transparent proxy. I don’t have that issue.

@loup001 Many thanks !

Small difference all the same with my problem :

In my IPFire configurations, the Web proxy service stops after several days (without reboot) and I can still access the GUI …

@xperimental Thanks for your reply !


Thank you for your quick reply !

I’m going to look at what I can check for ClamAV, but I was mainly thinking about the RAM gain recovered by ClamAV and which Web proxy might need … But this is only a newbie’s idea !

I don’t use clamav or squidclamav. Over the last two to two and a half years I have not had any issues with the web proxy on either my production machine or any of the vm’s that I use for testing out patch changes or new releases.

I just had a quick look at the referenced bug and the logs provided in it.

I am not very experienced in kernel aspects but I didn’t see anything about the squid proxy in the kernel log.

The squid log has a line that says “squid shutdown time 6 seconds” but there are no lines giving any hints or suggestions as to why it shutdown.

@pmueller’s suggestion of enabling debug is a good idea. Some more details on why squid is stopping are really needed to be able to figure out what needs to be fixed.

To be precise, it was me who manually shutdown clamAV and SquidClamav, and it was while doing this that the proxy web service didn’t seem to crash anymore…

@pmueller @bonnietwin Please, how do I activate debug mode ?

Clamav in IPFire is using clamd so the easiest way is to stop clamav and then edit clamd.conf which I believe is in /var/ipfire/clamav/
adding the line “LogVerbose yes”
This will enable verbose logging which is off by default.

There is also the option “Debug yes” for clamd.conf but this enables debug messages from libclamav which I believe would be used if you were wanting to have more detail about failures in the scanning for viruses so not applicable in this situation. ( but I could be wrong :slight_smile: )

It’s great, thank you @bonnietwin !

I added “LogVerbose yes” as you suggested and restarted clamAV.

I found a /var/log/squid/squidclamav.log file, is this the one that can give me some infos ?

Hi @steph78630

clamav logs to syslog so any messages will be in /var/log/messages which you can then grep probably for clamav or clam.

The squidclamav.log file covers any issues with squidclamav which is the interface software between clamav and squid.

To get debug set up in squidclamav you need to edit /etc/squidclamav.conf
You need to change the 0 in the line containing “debug 0” to 1,2 or 3.
From what I have read this debug setting will affect the performance of squidclamav so you should only have it higher than zero while you are doing your debug searching.

After editing the squidclamav.conf file you will need to press Save and Restart on the web proxy WUI page.

Hope that helps.

@bonnietwin , thanks again for all the details, I’ll try it all !

Unfortunately, the problem persists after stable core update 162 : After reboot, the Web proxy service is stopped again…

However, I no longer see this problem in operation since the modification of the cache management parameter (memory cache size: 256 MB to 10 MB - see @flaorus solution) and reactivation of ClamAV.

Problem related to the used / consumed RAM ?

Edit: Since the last update (core update 162), the Web Proxy service stops again while IPFire is running…