Web proxy stopped status post reboot

core 151. After reboot, IPF GUI/Status/web proxy/STOPPED** status.

/var/log/squid/cache.log results= FATAL: The redirector helpers are crashing too rapidly, need help!

Have to manually execute exec /usr/sbin/squid. Service starts but no caching occurs.

Below is screenshot of the web proxy config.

Anyone have suggestion? Cli-commands?


EDIT: Updated markdown for screenshot by Moderator.

Just try to disable ‘URLFilter’ and’ Update Accelerator’ ( the redirector helpers ) and enable them one by one.
When does the error return( squid only/squid+URLFilter/squid+UpdateAccel/squid+both redirectors)?

Try to change some settings in the “Network → Web Proxy”:
Memory cache size (MB): 10
Harddisk cache size (MB): 1024
then press the “save and restart” button.

Saving these ( arbitrary ) parameters restore possibly damaged files.
So ‘press the “save and restart” button’ may be a remedy.

Interesting to get a reply. Thank you. However, its still persistent issue. Since I do not reboot FW unless new update occurs, I only perform the cli command exec /usr/sbin/squid after reboot. I of course tried Nov 20 suggestion and YY suggestion. Still a no go.

Additionally, now I when I click " [Activate cachemanager:], all i see is menu screen…with 5-hidden links.

Clicking " [Cache Manager Interface] generates this error:
Internal Error: Missing Template MGR_INDEX

BTW, squid command within IPF shows this===> # squid
2021/10/01 13:34:23| WARNING: BCP 177 violation. Detected non-functional IPv6 loopback.

Can anyone suggest some cli commands?

NOTE: To be clear, since every update from Nov 2020, web proxy does not autostart. I have to manually autostart.
At all times, I do the cli version of pakfire to update/upgrade.

FWIW, my FW device has 64GB msata and 8G Ram

Model Family: Phison Driven OEM SSDs
Device Model: Hoodisk SSD
Serial Number: xxxxxxxxxxxxxxx
LU WWN Device Id: 0 000000 000000000
Firmware Version: xxxxxxxxx
User Capacity: 64,023,257,088 bytes [64.0 GB]
Sector Size: 512 bytes logical/physical
Rotation Rate: Solid State Device
Form Factor: mSATA
TRIM Command: Available
Device is: In smartctl database [for details use: -P show]
ATA Version is: ACS-4 (minor revision not indicated)
SATA Version is: SATA 3.2, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is: Fri Oct 1 13:40:09 2021 EDT
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

If squid doesn’t start, there should be errors in /var/log/messages, /var/log/squid/*.log.

1 Like

BTW: A quick search in Bugzilla didn’t show this issue.
Either it is solved by saving the config from the WebGUI ( repairing damaged files ), or most of this spurious errors are eliminated by the actual Core Update.

I may be wrong. But then the developer group needs more informations. As the error couldn’t be reproduced in average systems.

1 Like

You don’t have to worry about this message as per the following post


Thanks AB. I tried replying to your 1st email to all but it does not show up here. Regardless, squid generates a PID but not working… Below is what i was trying to send:
squid is running…but…same issue as mentioned in previous post

2021/09/30 18:16:13| Removing PID file (/var/run/squid.pid)
2021/10/01 13:16:27| Created PID file (/var/run/squid.pid)
2021/10/01 13:16:27 kid1| Current Directory is /root
2021/10/01 13:16:27 kid1| Starting Squid Cache version 4.15 for x86_64-pc-linux-gnu…
2021/10/01 13:16:27 kid1| Service Name: squid
2021/10/01 13:16:27 kid1| Process ID 27252
2021/10/01 13:16:27 kid1| Process Roles: worker
2021/10/01 13:16:27 kid1| With 1024 file descriptors available
2021/10/01 13:16:27 kid1| Initializing IP Cache…
2021/10/01 13:16:27 kid1| DNS Socket created at, FD 5
2021/10/01 13:16:27 kid1| Adding domain localdomain from /etc/resolv.conf
2021/10/01 13:16:27 kid1| Adding nameserver from /etc/resolv.conf
2021/10/01 13:16:27 kid1| helperOpenServers: Starting 4/4 ‘redirect_wrapper’ processes
2021/10/01 13:16:27 kid1| Logfile: opening log stdio:/var/log/squid/access.log
2021/10/01 13:16:27 kid1| Logfile: opening log stdio:/var/log/squid/user_agent.log
2021/10/01 13:16:27 kid1| Store logging disabled
2021/10/01 13:16:27 kid1| Swap maxSize 1048576 + 10240 KB, estimated 81447 objects
2021/10/01 13:16:27 kid1| Target number of buckets: 4072
2021/10/01 13:16:27 kid1| Using 8192 Store buckets
2021/10/01 13:16:27 kid1| Max Mem size: 10240 KB
2021/10/01 13:16:27 kid1| Max Swap size: 1048576 KB
2021/10/01 13:16:27 kid1| Rebuilding storage in /var/log/cache (clean log)
2021/10/01 13:16:27 kid1| Using Least Load store dir selection
2021/10/01 13:16:27 kid1| Current Directory is /root
2021/10/01 13:16:27 kid1| Finished loading MIME types and icons.
2021/10/01 13:16:27 kid1| HTCP Disabled.
2021/10/01 13:16:27 kid1| Squid plugin modules loaded: 0
2021/10/01 13:16:27 kid1| Adaptation support is off.
2021/10/01 13:16:27 kid1| Accepting HTTP Socket connections at local= remote=[::] FD 20 flags=9
2021/10/01 13:16:27 kid1| Accepting NAT intercepted HTTP Socket connections at local= remote=[::] FD 21 flags=41
2021/10/01 13:16:27 kid1| Done reading /var/log/cache swaplog (338 entries)
2021/10/01 13:16:27 kid1| Finished rebuilding storage from disk.
2021/10/01 13:16:27 kid1| 338 Entries scanned
2021/10/01 13:16:27 kid1| 0 Invalid entries.
2021/10/01 13:16:27 kid1| 0 With invalid flags.
2021/10/01 13:16:27 kid1| 338 Objects loaded.
2021/10/01 13:16:27 kid1| 0 Objects expired.
2021/10/01 13:16:27 kid1| 0 Objects cancelled.
2021/10/01 13:16:27 kid1| 0 Duplicate URLs purged.
2021/10/01 13:16:27 kid1| 0 Swapfile clashes avoided.
2021/10/01 13:16:27 kid1| Took 0.12 seconds (2842.27 objects/sec).
2021/10/01 13:16:27 kid1| Beginning Validation Procedure
2021/10/01 13:16:27 kid1| Completed Validation Procedure
2021/10/01 13:16:27 kid1| Validated 338 Entries
2021/10/01 13:16:27 kid1| store_swap_size = 36936.00 KB
2021/10/01 13:16:28 kid1| storeLateRelease: released 0 objects
2021/10/01 13:30:19| Current Directory is /root
2021/10/01 13:30:31| Current Directory is /root
2021/10/01 13:34:23| FATAL: Squid is already running: Found fresh instance PID file (/var/run/squid.pid) with PID 27250

I also tried Clear Squid Proxy Cache And Re-create the Cache Directories.==>.interestingly squid.conf had cache_dir aufs /var/log/cache…<==is this the correct path? the access/cache/user logs point to==>/var/log/squid/

BTW, /etc/init.d/squid status generates NO results…unlike other:
i.e /etc/init.d/unbound status
unbound is running with Process ID(s) 1588.

Also I do not get this response either:

Therefore, do I attempt to do a full re-install of 159?

EDIT: Quote reapplied by mod.

Was the response using the same email account? Or is there an alias involved?

If the IPFire Community sent a message to your email Account A, and you responded from your email Account B, I believe you’ll see an error.

Likewise there may be an error with an alias. (this one may be fixed. But I haven’t tried it in years)

of course…I selected the reply to list option.

BTW, reinstalled 159 from scratch…now cache manager does not want to function…Solution anyone???

Server reboots fine NOW with squid working correctly as well as giving me RESPONSES in cli mode…

Its very unusual…what is transpiring… started with ipcop 16 yrs ago… and now this…

Does not matter which cache server i use…same response: "Internal Error: Missing Template MGR_INDEX"

BUT, cache…DOES this error signify “squid” issues ongoing?

NOW, Of course proxy log viewer no longer shows any data


note: also chnaged proxy port to a new, other than default. cache mgr shows still same error.

When you get this screen occurring, go to the command line and see what you see in


The lines near then end of that file should be related to the message. There usually is a bit more info available together with the line number that had the problem and the filename involved.

1 Like

per your request : note: this is a FRESH install; Perm. is 755 for "above"path

[Fri Oct 01 21:56:49.932898 2021] [cgid:error] [pid 2462:tid 137624425584192] [client ] AH01264: script not found or unable to stat: /srv/web/ipfire/cgi-bin/cache_object:, referer:

[Fri Oct 01 23:03:18.215210 2021] [cgid:error] [pid 2458:tid 137624659723264] AH01239: cgid daemon process died, restarting

[Fri Oct 01 23:03:18.258407 2021] [mpm_event:notice] [pid 2458:tid 137624659723264] AH00491: caught SIGTERM, shutting down

[Sat Oct 02 11:23:45.618562 2021] [cgid:error] [pid 2498:tid 137114899109440] [client] AH01264: script not found or unable to stat: /srv/web/ipfire/cgi-bin/cache_object:, referer:

[Sat Oct 02 11:30:05.710451 2021] [cgid:error] [pid 2498:tid 137114775692864] [client] AH01264: script not found or unable to stat: /srv/web/ipfire/cgi-bin/cache_object:, referer:

Is there a manual way to start cgi daemon?

In that directory are all the cgi programs that run the pages for IPFire. In addition web programs that come with some of the installed programs, like the web proxy squid, are also stored there. cachemgr.cgi is one of those programs that is part of the squid package.

From searching it seems that the MGR_INDEX is also related to a squid program.

Could you check if cachemgr.cgi is present in /srv/web/ipfire/cgi-bin If it is not then something has gone wrong during your fresh install. If it is present there does it have the same ownership and permissions as all the other cgi files in that directory?

yes…they are all 755

Then I am running out of ideas what might be causing it. I have never seen anything like you are experiencing in any of my updates or in any fresh installs on my vm testbed.

Maybe you should try raising it as a bug.

Your IPFire Community email address and password work on the IPFire bugzilla to login.

IPFire wiki on Bugzilla and bug reporting

1 Like

JUST DOWNLOADED ipfire-2.27.x86_64-full-core160.ISO
STILL GETTING ERROR: "Internal Error: Missing Template MGR_INDEX"

[squid is running with Process ID(s) 10632 10629.]
[usr/lib/squid/unlinkd is not running.]


Please don’t shout. It is not polite.

On the Status - Services WUI page does the Web Proxy show as RUNNING in green or STOPPED in red. If it is stopped what happens if you click on the Save and Restart button at the bottom of the Web Proxy WUI page? Does it now start or does it stay stopped?

My Web Proxy shows as running and when I click the Activate cachemanager: link in the Web Proxy WUI page I get the Cache Manager Interface page from the squid cachemgr.cgi file.

What do you have in your /var/ipfire/proxy/cachemgr.conf file

You should have

based on the values in your earlier posts.

The cachemgr.cgi file permissions/ownership should be
-rwxr-xr-x 1 root root 84K Aug 9 12:01 /srv/web/ipfire/cgi-bin/cachemgr.cgi

The md5sum of this file should be
7afba0da774a2594abb99fce6cbf016e /srv/web/ipfire/cgi-bin/cachemgr.cgi

1 Like