VLAN Tagging Required on Red, How?

I have an FTTP connection through CityFibre. To get access to the internet you need to tag your DHCP connection with VLAN ID 911.

I cannot for love nor money figure out how to do this with IPfire. Any idea how to tag my Red/WAN connection to get access to the internet?

I have an IPoE (DHCP) connection as opposed to PPoE. Therefore I just need to tag my Red connection with an id of 911 and it should work. But again, how do I do this?

Install IPFire as usual with DHCP on red, then go to Network → Zone Configuration in the WebUI and configure the vlan on red.



I tried that before posting this, it still doesn’t work with no connection to the internet.

After you did that change on the zone configuration, did you reboot?

Yes, and then it just was stuck on “connecting” the whole time. No change.

What Arne described is the correct way to configure this. So this is supported.

If it is not working there could be a couple of other factors:

  • (We haven’t seen this in ages, but) Does your hardware support VLANs?
  • Are you sure you need to use DHCP and not PPPoE? I have not seen an ISP that is using this kind of configuration in the wild.

You can check with “tcpdump -i red0 -nn” on the console what packets are passing the Interface. If you don’t see anything coming back from the ISP side, you might have an incorrect VLAN ID?