V 170 and Cox DNS not resolving

The IPFire box is set to DHCP for the lease from the cable modem while the Green is a mix of static for devices and DHCP for roaming items.

The DHCP from COX provided Primary name server: Secondary name server: I was unable to get name resolution to function till I disabled the Cox DNS and used and Typically I go to the shell and do a ping to determine if connectivity is working on Red and Green.

What I did was to test an IPad, and Cell phone and Laptop connected to the same Cable modem to see if there was name resolution. There is proper name resolution. The cell were wireless and the laptop was Lan.

The device has been power cycled several times.

I have went back my to PFSense 2.4 p1 and it also provides proper name resolution with the above DNS servers. Tested this V 2.6 and all seems to work accordingly.

I have set up some friends at home with earlier versions of IPFire and Cox and had no issues.

I did have the IPS enabled but took that off to see if that made a difference. It did not make any difference.

Also there was intermittent loss of connectivity LAN cable to IPfire box. .1 becomes non pingable. Then it does. The IPFire box is an HP 600 Gen1 with 16gb Ram and new SSD. Has most recent release of HP firmware. The internal LAN is an Intel Based NIC while the External is RTL.

Looked at the various sys logs and found nothing obvious or odd.

Have used this make and model for friends at home with same NIC. I did find that 169 would not find the add on NIC which was from Startech. A new one ordered last week worked. That older NIC was functioning in a Windows 10 20h2 on an HP 600G1. Just got a new one and it worked.

Start here

Hi Shawn.

Thank you for the information. I had done the following steps suggested and that did provide DNS resolution.

What I cannot figure out, unless COX is using an Unsecured DNS server, why it did not work. I have used multiple earlier versions without issue.

I) Any device connecting to the Cox Cable modem will get proper DHCP II address and name resolution unless it is running IPFire 170. I don’t have the older distros to backwards test.

  1. I know that V 167 still worked with the COX DNS as I helped a friend at home. What they do for updates is up to them. They never have called me since April on any issues.

  2. PFsense 2.4 p1 and 2.6 work properly but to set up the IPS/IDS is a cumbersome. I like the configuration used in IPFire as it is very close to Fortigate product family with the services enabled. They do not expose that very conveniently. I like the fact that IPFire lets the user know that the various CPU vulnerabilities have been cured. The other product is silent.

  3. When use the non supplied DNS from COX, my partners VPN connection to work would not connect consitently. I could attribute this to connection issues with the host but the alternate connections would not work or were unstable. This is strange but it has worked reliably for over 2 years. Switched to PFSense and the CISCO VPN software connected correctly and stayed connected. With IPFire it kept dropping the connection.

This one has me a bit puzzled as to why 167 worked fine and 170 just says nope nanda. My internal machines that have statics and pointed to a well know DNS server had no issues or statically asigned DNS via the UI.

I know there have been BIND and Kernel changes.

There is something there. An older Startech NIC was not seen until a new one was installed. The old one worked and still works in a Win 10 environment. I can change hardware as to the PC and just swap in the SSD drive as they are same machines but with different FW.

I can continue to tinker or wait for the next Rev to see if something changes.

Take care and thanks for all of the help. I have to look to see if Wireshark can be installed.