Update Core 161 to 162: WLanAP not working

Hello everybody,
since I updated my ipfire to core 162 the WLanAP does not start any more. And I can not find any logfiles regarding hostapd. Any suggestions where to find logs?

Thank you!


Maybe your interface is not detected anymore since the upgrade. Go to the web interface, Network > Zone Configuration and check if there is a physical interface assigned to BLUE.
Using the terminal, you could also check the output content of the dmesg command to look for any hardware-related error.

1 Like

Thank you.
Zone Configuration shows the interface with correct MAC, dmesg only shows firewall drops and forwards, nothing hardware related. :worried:

Hallo @dagerba,

Welcome to the IPFire community.

I would try running from your console
/etc/init.d/hostapd status
to confirm that hostapd is not running and then run
/etc/init.d/hostapd/ start
and you should then see any messages from hostapd related to its attempt to startup and those should help to give guidance on what the problem might be.

1 Like

Is the plugin hostapd installed?

from the console:


does it show you wifi card? Also, does

ip a show blue0

show the blue interface?

1 Like

hostapd is installed. The access point worked well for a long time before the update.

lspci is no help, as the wifi adapter is usb. But lsusb shows the adapter.

ip a show blue0 shows the interface with correct MAC an IP.

1 Like

/etc/init.d/hostapd status answers “is not running”

/etc/init.d/hostapd/ start looks correct to me:
Starting hostapd…
blue0: interface state UNINITIALIZED->COUNTRY_UPDATE
ACS: Automatic channel selection started, this may take a bit
blue0: interface state COUNTRY_UPDATE->ACS

But no connection possible, no wifi visible.
A minute later /etc/init.d/hostapd status reoprts “is not running” again. No other messages inbetween.

I saw that you mentioned that your WLAN interface is a usb type.

There is an issue with usb connections that has been discussed in other threads and there is an IPFire bug raised on it.


Maybe your setup is being affected by the same bug.

1 Like

How about /var/log/bootlog? Anything unusual there compared to the older ones (such as /var/log/bootlog.1.gz which of course you have to unpack first), before the update?

Check your channel setting. At my knowlege automatic channel select (ACS) is only supported by atheros based PCI cards (ath9k-ath11k) all others must configured by the user.


Ok, Arnes suggestion to manually set the channel fixed the problem. A bit confusing, that it worked with automatic select before the update, but no matter. If it works, the admin is happy and does not aks why :sunglasses:
Thank you to everybody for your thoughts and suggestions, I wish you a happy new year!
Greetings from Bavaria, Michael