Update Accelerator - https repo

Seems like Linux downloads in /usr/sbin/updxlrator
does not catch packages from https repos

($source_url =~ m@^[h|f]t?tp://[^?]+\.(pkg\.tar\.xz|deb|rpm)$@i) ||

I have tried to add new line to serve my Oracle linux hosts

($source_url =~ m@^https://yum.*\.rpm$@i)

and after that clicked “Save and restart” on the “Update accelerator configuration”
I tried to download packages “dnf update --downloadonly”
but nothing was added to /var/updatecache/linux/

and also I noticed that even log enabled for Accelerator - log file does not create,
if create it manually also nothing happened (no entries in the flle)

To check the regular expression, it would be nice to have an example for a download URL.

BTW: capturing from HTTPS servers doesn’t function. This isn’t possible with the Squid proxy, as far as I know.

seems like you are right. but http only is almost useless option in 2024.
I got cached single package - nginx from its repo)

probably I have to increase “Max object size” and “Harddisk cache size” for squid itself…