UGH! - All my VPN certificates expired near the same day

First off I just want to say, “I hate computers!”. They always do what they are told!

Two years, three months, and three days ago I set up IPsec for the first time. And it has worked GREAT until yesterday! IPsec is easy to install and allows me to seamlessly connect from my Mac or iPhone to my network and to one other remote network. I love IPsec! Strike that. I loved it! Past tense!

Last night, when I tried to connect via IPsec VPN, I got these scary messages on my iPhone:

Why did the remote network AND my home network both stop working with IPsec?!?

It turns out is was not an Operation System upgrade and it was not an CU 180 upgrade.

I started using IPsec on or near the same day and it is an expiration date that bit me!

Why can’t my computer be smarter? It should know better!

Note to self: add a Note to IPsec wiki about certificates expiring in 825 days!

No need to troubleshoot, I can see a screw loose that is attached to the my keyboard!


Yes, this has bit me too – IIRC the default was changed from something like ten years to two, although you can change the default in some config file. It would be nice seeing the expiry date in the list, though. :slight_smile:

1 Like

Maybe you set up in the same day both? :smiley:

1 Like