Thunderbird Email Client

Hello, as new to ipfire, trying to resolve problems alone by searching web. But as I installed and made it to work, having problem with Thunderbird mail, that cannot receive or send mail. I set in Preferences>Network>“Configure how Thunderbird connects to Internet”>Settings>Manual Proxy, the ipfire address and 800 port, so it asks for user name and password, but after that cannot receive or send mails. Please help.

I have never had to adjust anything in IPFire for email clients to work or adjust anything in the client. Did you try removing those preferences in your client, reset to default and try to send/receive?

2 Likes

Yes I did, but then it does nothing because the ipfire is installed on a 2 NIC HP Thin Client working as web proxy-firewall Server. So everything has to pass through it to access network. Also having the same problem with Viber, Skype, GoogleEarth, so I think it’s common problem for every client that asks network connection. Tried to open a lot of ports for TCP and UDP in firewall, also mail services as IMAP etc, but nothing seems to work. Tried by deactivating proxy and any other service in WebProxy menu, no luck. So thinking that the only solution could be a way to bypass ipfire server for some Apps-Clients, is it possible?

Few minutes ago tried by setting “system-wide proxy settings” (Debian Bullseye), making a “proxy.sh” file in /etc/profile.d, and GoogleEarthPro worked, just by asking proxy user name and password, but Viber don’t.

No luck with thunderbird

I have thunderbird working behind my ipfire with Proxy and IPS and it runs perfectly.
For the mere sending and receiving mails the proxy is not active. But it is active for having access to cloud services via https (calender, addressbook).
Are there any firewall rules in your system active which affects the e-mail traffic?

1 Like

Please, what you mean with this? How cannot been active if you don’t deactivate it?
I have opened any service and port depends on send or receive mail. What’s your OS? I’m using Debian Bullseye. Could it be an OS problem in communicating with ipfire? Also, Viber from mobile connected on wifi to ipfire works perfect. Any thought please, or can I check by someway what really happens? Thank you for your time to me.

Tried more mail clients as Sylpheed, Evolution, all the same: NO ACCESS.

This page shows how to setup a proxy in Debian.

I think you configured the SSL proxy and Thunderbird cannot authenticate.

then the ipfire should not the limiter.

I use linux Opensuse 15.3

Possibly it is in the configuration of your Thunderbird installation something wrong.
Correct account configuration?
o ports?
o user ID?
o PW
Personally I use Thunderbird on Linux an MS.

# set proxy config via profile.d - should apply for all users
# http/https/ftp/no_proxy
export http_proxy="user:password@http://192.168.2.2:800/"
export https_proxy="user:password@http://192.168.2.2:800/"
export ftp_proxy="user:password@http://192.168.2.2:800/"
export no_proxy="127.0.0.1,localhost"

# For curl
export HTTP_PROXY="user:password@http://192.168.2.2:800/"
export HTTPS_PROXY="user:password@http://192.168.2.2:800/"
export FTP_PROXY="user:password@http://192.168.2.2:800/"
export NO_PROXY="127.0.0.1,localhost"

That’s my debian /etc/profile.d/proxy.sh.
Set to thunderbird proxy “use system proxy settings”.
Anything else to try please?



I’m very disappointed. Tried a lot of settings, added and removed some and all of ACL’s, now trying to deny access to “minecraft” site for setting up additional children accounts, I made a new blacklist>>>not worked, added domains into onlinegames list>>>not worked, tried rebooting, reset and start over…I’m a bit to give up. Seems like everything is either wrong neither something strange happens, I’m not an expert but it looks like very difficult to make it as I want.

George,

I enabled the web proxy on my ipfire, just clicked on “enabled on Green” – no other settings.
Went to the bottom, save and restart.

From a client (Linux Mint 19.3) that has thunderbird, I sent email to another account and using my Thunderbird, I was able to get that email. My thunderbird settings … imap, incoming on port 993, outgoing (SMTP) on port 465. Connection Security SSL/TLS. I hope this helps.

That’s the same settings as in my thunderbird, I know how to do that, somewhere there’s a small setting that makes all trouble. Anyway, tomorrow I’ll make a new installation and start over from …0. Any idea about not filtering custom blacklist, but it’s OK for deny porn sites?