Telephone calls cutted after ca. 15 minutes

Hi,

i have a Voip-Telekom Connection for Internet and Telephone. System Configuration is
Draytek-Modem <-> IPFire <-> Fritzbox. I configured the Fritzbox to use the existing Internet Connection. My dect-telephones (Fritzphone) are connected to my fritzbox. In the past, there was no problem with calls (and I have no special Firewall-Rules/Port Forwarding configurations in my ipfire. Since the last Update(s) (141 or 142) I have a call interrupt after ca. 15 minutes. Do I need a special firewall configuration ord port forwardings now? If yes, could you tell me exactly what i have to configure?

Thank you for your support in advance.

Iam really interested in your posting because i watched the same thing. I use my Voip Box the same way like you (behind IPFire) no forwardings needed/ no special rules. I saw it only 2 time and only with the same person. All other calls with many diffrent others had no problems and many was more then 15 minutes (with Core 142). So i thought it was a temporary problem because nowerdays you read a lot about the whole world wide traffic.

I keep watching now if i see something again at home.

What? Chinese pls!!!

Btw. Tulpen knicken is very bad!!!

Well its true iam german. And i really speak much better german then english :wink:

But

https://community.ipfire.org/faq

Please post in English only

German is forbidden i feel sorry :frowning:

Back to topic. Yeah thx i already know such tips but i use many years now voip without any rules. I really dont like forwarding rules. If i can use what i want without any rules, i prefer that way.

The best thing you can do dont open anything from the outside. Only it’s absolute necessary.

And as i said at the moment it happen only 2 times the last days. Never before. So i keep watching.

Better then roses :wink:

Ok, my mistake. I didn’t read the faq before. So I’ll summarize it in english again. There was a thread in the old ipfire forum (in german) already to the mentioned problem. Unfortunately this information wasn’t transferred into the new wiki and, in my opinion, is a very germany based problem with our telco Telekom who didn’t implement the sip/voip telephony very well.
Nevertheless, the suggestion in this thread was, to forward 2 sip ports (5060 and 5061) and 2 rtp ports (7078 and 7097) directly to the fritzbox who handles the telephony.

Do you have in all calls disconnects after 15 minutes?

Hi,
Status update. I’ve tried outgoing and incoming calls. Both were interupted after ca. 30 minutes. :unamused:
So, I will search for another solution.

i dont know mutch about Fritzbox but do you have firewall/firewall options/Application Layer Gateways/SIP turned on?
i believe SIP is a kind of voice over ip, i use SIP for my mobile service and i havent been cut off by ipfire yet

Hi,
Thanks for your hint. Yes, this was the first option, I’ve verified.

image

I dont have any ALG in use. I remember especially for sip i read in the past that can be give problems.

Give a try to turn on SIP.

He already have it turn on and he have problems. I dont have turned on and have no problems only 2 times. So i dont understand what you mean :wink:

Thanks for your experience :slight_smile:

I looked at my settings and one thing gets my attention.

Also long time ago one setting was necessary to change. In the Fritz Schachtel :wink:

Eigene Rufnummern --> Anschlusseinstellungen --> Portweiterleitung des Internet-Routers für Telefonie aktiv halten. --> 30 Sek.

So maybe you say now but i thought you have no Forwarding Rules. Yes thats true i dont have any but this setting was, as i said, in the past necessary. It helps me.

Yes, I know, activated long time ago.

But still interrupts.

try this in shell:

echo 360 > /proc/sys/net/netfilter/nf_conntrack_udp_timeout_stream
echo 180 >/proc/sys/net/netfilter/nf_conntrack_udp_timeout

Hi,

thank you very much for your advice. Since a long time the dissconnect dissapear so I have to wait until it happen again.

Same problem here, already tried conntrack settings and the fritzbox keep alive setting. Phone calls get interrupted after approximately 15 to 20 Minutes. Nothing in logs (ids/firewall) to debug this. Any ideas?

You guys need to find out, how the call is ended. Is it just (one way) audio silence or is the call interrupted by SIP (something like busy tone one one/both ends)?.

For testing, you should define two appropriate forwarding rules in IPFire. (–> Fritzbox:5060 - UDP, -->Fritzbox:Fixed RTP range - UDP)
@tulpenknicker, forwarding rules are not a bad thing in general, in certain cases they are even mandatory.
In case of a SIP client which needs to be reachable from the internet at any time, I would not relay on the firewall keeping the right connections open all the time, even if the client has some “keepalive” functionality.
I had cases (and complains) where a PBX was not reachable for hours cause the FW closed the incoming SIP UDP connection - despite an active keeplive.
Same for the RTP protocol, I had situations where the firewall was too strict to conntrack RTP traffic successful which caused annoying one way audio (you can’t hear the other party) in the end.