Stuck trying to install ipfire 2.25 core 144 on PC Engine

I’m trying to reinstall ipfire on my PC Engine using the serial console but I’m stuck at this screen:


I can enter the admin password, press RETURN. Then I get this screen and the installer hangs for more than 15 minutes.

Note: I’ve successfully installed IPfire a couple of times in the past. I just wanted to reinstall because /boot is full (the old install was done with just 64MB filesystem).

Any ideas how to proceed?

Is there a place where I could download an older image and then upgrade via pakfire?

Also: Any suggestions how to get rid of the junk ("?" characters) on the screen?

1 Like

Maybe serial cable wrong?.


No. This is the 5th screen of the installer. Cable is working.

How can I simply get rid of the installer and restore the backup manually?

I found a solution: Create a USB stick using TinyCore Linux from the PC Engine homepage:

Copy the backup on the stick as well.

Boot using TinyCore.

Eventually, you’ll get a root prompt.

cd /media/usbhd-sda4

Make sure you’re in the right folder:

ls -al var/ipfire/

should list some files.

Restore the backup:
tar xvzf /media/SYSLINUX/

note: Linux will try to complete the name for you when you press TAB.

Reboot using reboot

One thing was weird, though: My network settings were gone. To fix that, I had to run the command setup after booting ipfire.

Now I’m uneasy how much of my firewall the above command could restore…

Also, I can ping the box but can’t connect via ssh or web browser despite both services running:

# /etc/init.d/apache status
httpd is running with Process ID(s) 13247 13245 12260.
# /etc/init.d/sshd status
sshd is running with Process ID(s) 12246.

Found solution for the ssh/apache problem:

/etc/init.d/firewall restart

will restart the firewall after changing the network config.

Same problem here with a new installation on an apu2, will try again tomorrow with core 143.

Why the hell is there a seperate post for the same thing? [BUG] Weird characters in installer (serial console)

My problem ist that the screen hangs at this dialog "Setting IPFire ‘admin’ user password…

Tried it with 143 and 144.

I was able to pass the dialog and successfully install IPFire on my apu2 with core 142.

I just installed a Serial PC Engines using the 144 and have had no problems.


I run into the same issue it has nothing to do with the terminal or the weird line characters.

The reason are missing random numbers. As workaround use an usb stick and connect it to the apu and remove it some times to generate some interrupts for gathering ramdomness.

We will change the initskript order with core145 to fix this…

I can confirm, too. Arne was quicker in posting :slight_smile:

I would recommend installing Core Update 143 and upgrade from there as a workaround.