<SOLVED> Update from 141 to 142 broke red

the configuration worked from core update138 flawlessly but with 142 the ppp modem cannot connect anymore.

grep -iE ‘error|fail|not’ /var/log/bootlog

[ 0.333341] mtrr: probably your BIOS does not setup all CPUs.

[ 0.848195] pci 0000:00:13.0: PME# does not work under D3, disabling it

[ 5.071196] GHES: Failed to enable APEI firmware first mode.

[ 10.295513] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:05:00.0.bin failed with error -2

[ 10.295566] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/cal-pci-0000:05:00.0.bin failed with error -2

[ 10.296252] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-6.bin failed with error -2

[ 10.335065] ath10k_pci 0000:05:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2

[ 11.597907] FAT-fs (sda2): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

The FAT-fs error may result from the problem, that ipfire cannot be shutdown with power-off (so i have to unplug the cable - when discs are synced, Prepare for halt… has passed and light on APU is off of course …)
Even with “shutdown -h now” the system restarts with “reboot: Power down” … maybe the runlevel has a wrong acpi flag or the coreboot of the apu4 has some WOL function, but i could not even figure out how to enter the coreboot (if that is possible)

If i remember correct you must press F10 at boot then setup. But iam not sure what you can all change there.

1 Like

The command is “poweroff” rather than “power-off”.

Even with the correct command, you might still get the message:

“FAT-fs (sda2): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.”

I get it with sda1 (/boot) on 3 different ARM boards, even when correctly powered down. Your sda2 is probably /boot/efi.

About “poweroff”:
This is NOT a typed command from myself - i used the shutdown button from the menu in ipfire and this does exactly the same thing as when i enter “shutdown -h now” in cmdline:

The system kills every process, syncs the disk and then shows
“Preparing for halt …
reboot: Power down”

I just see it in the output of my serial console.

After 2 seconds the APU-board/ipfire-instance reboots…

Sounds like a hardware or bios fault. My apu1 and 2 are not restarting after poweroff.
I don’t remember that the apu support WoL but im not sure. F10 is the correct key to enter the coreboot but keep in mind that some systems like “ubuntu” catch F10 for the menu of the terminal window. In this case you need an other programm like putty.


The IPFire 142 started today with red interface working - so i keep watching that behavior (but mark as solved in between)
F10 worked in minicom, but network boot was disabled - so i will have to investigate further about the automatic reboot issue…

Thx anyone for instant help! :+1: :slightly_smiling_face: