[Solved] Openvpn p12 file password error if you download only the file (p12 in zip file work) on core 167

Hi! I am using openvpn on my phone, I installed it some time ago and it works fine.

But when I now tried to install on another person’s phone, the installation app for certificates on Android will not accept the password for the downloaded p12 file from Ipfire Openvpn GUI. I only download the p12 file, not the zip pack.

I also tried the p12 file on my phone, and it won’t accept the password. Created some more p12 files via Ipfire Openvpn GUI with really easy passwords, but the android cert app doesn’t accept the passwords on those either.

Maybe similar to this? IPSec Windows Client Setup

Or am I missing something as it was some time ago I did this before?

I am with IPFire 2.27 (x86_64) - Core Update 167

Edit: Just tried to download the zip pack with both ovpn file and p12 file. The p12 file in the zip file worked just fine with Android cert app. So I guess there is some problem when only downloading the p12 file

Edit 2: Maybe it is a bug? I post this on https://bugzilla.ipfire.org/ so my betters can judge

Edit 3: Direct link to bug post: 12883 – Openvpn p12 file password don't work if you only download the file (p12 in zip file work)

1 Like

Hi @raffe good afternoon from Spain.

I don’t have much idea on the subject, but I generate a certificate without a password and then I download the “insecure” package and that is the one that I install from the OpenVPN app.

It may not be the safest or the best, but it works for me.

Maybe someone with more knowledge can explain a better way.


See updates on the bug report.

1 Like

@raffe Please correct the link to lead to this reported error.

Size of downloaded .p12 files before correction in ovpnmain.cgi


Size of downloaded .p12 files after correction in ovpnmain.cgi



I did a quick tests of importing a .p12 file on OpenVPNConnect v3.3.6. (Win10)

1.Before correction in ovpnmain.cgi
-.p12 file from the downloaded zip - import OK
-.p12 file downloaded directly - import failed

2.After correction in ovpnmain.cgi
Both files - import OK

Passwords were used when adding the RoadWarrior connection.



Downloading an application file as a text based file causes some extra characters or spaces to be added under certain conditions. I found equivalent problems that people have had with other cert files by searching on the internet.

@tphz good to know that you also confirmed that the fix solves the problem. If you could add a comment to the bug report to that effect, it would be good.


I just updated my openvpn Android road warrior recently
It was a pain.
Had to add 2 of the 3 files from the zip package.
Then tried to connect.
It then popped up to add cert.
Can’t remember if I had a password To add too.
But it worked.
Strange that I had to add cert. After attempting to connect.

Ok, now there is a direct link to bug post in first post in this thread :slight_smile:

1 Like

Good news - the patch has been accepted and merged into what will be issued as CU169