Serial-USB via Putty on NanoBox?

I break my NanoBox with installing 159 upgrade of ipfire (it does not support 5.x kernel). So I installed 158 and tried to get connection via usb-serial (UART). But I get just black screen, no connection.

Does anybody know such problem?


I ever get a connection with 115200 Baud over a cross-over cable.

1 Like

maby I do something wrong… just following this tutorial: - Serial Console tried it on windows and linux. Same output… just empty screen.

1 Like

Are you sure you selected the right interface? ( driver/name should something like USB-Serial adapter or the chip FTDxxx for example )
You must use a cross-over cable. ( RX connected to TX, and vice versa ) A 1:1 cable doesn’t help, it connects RX with RX, …

1 Like

rather sure… DSD TECH SH-U09C5

I don’t understand this.
I connected it as followed:

  • 5V to VCC
  • GND to GND
  • TX to TXD
  • RX to RXD

So, should I just change TX to RXD and RX to TXD?

Short answer: yes.
I’ve just edited the wiki page for clarification.


1 Like

hmm… just the same issue… empty screen on windows AND linux

Do you have a second PC and a second serial device?
Then you can test connecting the two computers.

EDIT: with cross-over I thought of a null modem cable. Sorry for the wrong naming. :frowning:

These are two PCs, one linux, oder windows.
I have no second serial device. So maby the whole hardware is somehow broken.
I don’t understand much of serial, so i know no difference between null modem and cross-over :smiley: maby you can also write the thing with RX to TX and TX to RX… just for guys like me.

Wikipedia gives the following two diagrams
Fully connected cable
minimal wiring ( without handshake )

I don’t connect the VCC wire due to fear of pushing 5V into a 3.3V system.


DSD TECH SH-U09C5 can be set to 5V

How do you connect to the serial interface of your NanoBox?
I can’t find a manual of the box, so it is difficult to look at possible problems on this side.

  • Adapter to ipfire
  • 5V to VCC
  • GND to GND
  • TXD to RX (IOA5)
  • RXD to TX (IOA4)

it’s labeled on the NanoBox. Maby they make some mistake on routing RX and TX to the IOA, because I have 6 more of them (IOA11-IOA16). But RX and TX is labeled on IOA5 and 4.