Selected interface is not a WLAN card

I did it in the same way, but my bridge is not working.
Wifi or eth is working.
The GUI for wlanAP shows: Ausgewähltes Interface ist keine WLAN-Karte!

EDIT: in English
The GUI for wlanAP shows: Selected interface is not a WLAN card!

Same error message over here.
Observations:

  • first, only the LAN if was added to the bridge
  • removed from bridge ; reboot
  • re-added to bridge ; reboot
  • ! the green LAN if was added as only member to the bridge

Reverting to former back-up config now.

Re-building bridge, enabling STP tickmark:

  • ! the green LAN interface was added as only member to the bridge, again.

Reverting to simpler config: Bridge soleyly over WLAN card.

  • WLAN AP: “Selected interface is not a wirless lan card!”
  • “Remove selected interface”
  • “Please select the wireless lan interface” = options: [ blue0 | green0 ]
  • select blue0
  • WLAN AP: “Selected interface is not a wirless lan card!” again
  • brctl show:
  • bridge name bridge id STP enabled interfaces
  • blue0 8000.02cff6a4beb8 yes
  • NOTE: interfaces ← NONE !

@Sammy-Bulldog: could you please ssh into your IPFire
and call

  • brctl show
  • ifconfig

please?

Manually reverting to former Zone config (blue0 WLan If only) again.
Disabling MAC Address filtering -not plausible, but just for a test-
and re-building bridge from scratch:
brctl show
bridge name bridge id STP enabled interfaces
blue0 8000.027b0aca8a6e no eth2

! eth2 is my GREEN LAN Interface !

Sorry, but I can’t deny the impression that
“Zone Configuration” → “NIC Assignment” → “Bridge” seems broken a.t.m.

Next OBSERVATION:
Restoring main IPFire backup and then hostapd backup afterwards & reboot,

  • the new ssh=enabled config gets correctly deleted,
  • the old ssh=disabled config gets correctly implemented,
  • the entry disabling MAC Address filtering temporarily entered gets correctly deleted also,
  • but
  • the new BLUE Bridge Zone Configuration is still active,
  • the old singular Zone Configuration is not being restored
  • reverting manually & reboot again
  • afterwards,
  • “Access Point Configuration” correctly and completely shows up again.

What is the current valid place for providing bug reports?
I did not find any “create-new-account” button on bugzilla.ipfire.org.

You can find this several times here in the forum and also in our lovely wiki :wink:

Create account for forum, wiki, bugzilla …

In other words: If you can login “here” you already can login “there” :wink:

Having tried that, I failed - too tired:
This morning I realized having used a wrong one of my email addresses! Shame on me …
@Tulpenknicker: Thanks a lot!
Suggestion: Add your hint as a link into [wiki.ipfire.org - Bugzilla].

Your credentials working for the wiki as well, so you are able to add this information to the wiki by yourself :-). You do not have to but at least I want to provide this information for everyone reading this later on.

Jonatan

All can already know this if they read the information behind my provided link above :wink:

Thats why i waited if he maybe comes to the same conclusion :wink:

Edit. Have done it by myself now :slight_smile:

Yes, I did, indeed - congratulations for being quicker …
Admittedly, having spent hours / whole night answering questions,
this one as well as a To-Do “New Bug” entry had to wait :wink:
Thanks anyway!

Exploiting some user-free time today, I used “Network” → “Zone configuration”
for combining eth0 and eth3 into one bridge for “Orange” with success:

  • ssh → brctl show:
  • bridge name: orange0
  • interfaces: eth2 , eth3

and back again also.

Thus the due bug report can be limited to combinations of LAN with WLAN into a „Blue“ bridge.

1 Like

Bug 12601 -
zone configuration / hostapd:
Combining WLAN if with free LAN if into a common “Blue” bridge fails

I can not check this myself sorry, no free NIC. But it seems @ms itself have a working blue Lan / Wifi bridge here.

Hope this info can be usefull in some way…

Perhaps I’m friggin’ blind - didn’t catch what you are pointing at.

In case you are pointing at STP: playing around with that did not help either …

Thanks.

A little story on this topic. I’ve seen a lot of postings in the past where people have complained that the zone configuration not to work as it should. I saw postings, if I remember correctly, that @luani was working on this and that this should be resolved now. Now I read your posting and meant to understand that you said this still does not work with blue wifi/lan. All I meant is if STP works, it should also work without it. And it just doesn’t work under certain circumstances, which is unclear at the moment, but not absolutely not working.

Perhaps better in other words. What I mean is, it seems blue wifi/lan bridge works for some and for some under certain circumstances not. BUT not, it basically does not work for anyone.

If I completely misinterpreted your posting, just ignore it :wink:

As i said before, I hope… :grin:

1 Like

@tulpenknicker , I was puzzled because I did not find anything concerning @ms in the Blog post your link provided …

Thanks for your clarification, anyway!
To me, this suggests collecting working and non-working examples is needed in order to further fence this problem in.

@metalac , @Sammy-Bulldog :
Could you please be so kind as to also disclose your HW involved,
as well as IPFire core / hostapd version?
Thanks!

I just discovered that hostap - hostapd/wpa_supplicant displays hostap_2_9 as latest stable release,
whereas “hostapd -v” displays “hostapd v2.10-devel”.

Having noticed 12585 – Update with core 154 stops hostapd on some hardware.
→ “Downgrading hostapd from 581dfcc-54 to 2.9-52 fixed it”,
I downgraded to hostapd-2.9-52.ipfire also, but to no avail:
Again “brctl show” listed my green eth if as only single member.
And the error message from the title as well.
So I switched back again.