Second NIC does not show on RPi 3 Model B

Hello and thank you for your time. I am new with this sort of system, so please excuse me if a have not supplied the correct information - i don’t know what that would be.

I have installed IPfire on a raspberry Pi 3 Model B. The first time around everything worked ok, I could assign LAN to green and wifi to red. Then i tried to redo the setup as i had missed some things with the rest of the setup and now I only have one interface - the wired connection.

It does not appear to be a problem for others as I have not been able to find it elsewhere.
I am totally in the dark as how to solve it.

When i boot the Pi with Raspberry Pi OS, the WiFi works, but as soon as I start the IPFire, it will not recognize the wireless NIC.

I thought it was a driver issue, and so I tried this:

, but it did not make a difference.

If anybody has any ideas, it would be greatly appreciated :slight_smile: and if more information is needed (which i expect), I will gladly provide it, but do let me know how to get it :slight_smile:
Thank you

Sometimes there is a problem in the setup. If you want to reassign the nic’s remove all assignments and after this all nic’s should detected again.

1 Like

Thank you for your reply.
Should i finish the setup before it can detect them again?

I did try to remove the assignments, but i do not believe I have completed the setup with no assignments.
If I just removed the assignments without completing the setup, the other NIC did not reappear.

I will try if I can complete the setup without any NICs assigned and if that resolves the problem afterwards.
Again, thank you :slight_smile:

1 Like

Thank you for your suggestion @arne_f. I just tried removing any assignments, completing the setup, rebooting and check if the two NICs would show again. They did not, so I still only have the ethernet NIC available.

Any other inputs are very welcome too! :slight_smile:

Which exact board you have? I have tested this with Core159 (armv6l and aarch64) on a RPi 3B V1.2 (same as in the wiki picture)
Both correct detect the LAN and WLAN Nic’s

I have been running it on a Raspberry Pi Model B V1.2 as well.
The image I have used was the:
IPFire 2.25 - Core Update 158 for arm Flash Image (are there different ones to choose?).

Should i give aarch64 a go? The one marked experimental?

Would that run on the Pi?

Both images found on - IPFire 2.25 - Core Update 158

Thank you :slight_smile:

Edit: Realizing after posting, that I have used Core 158, I looked for Core159, but I do not see it on the webpage. Could the problem stem from using 158? Although the system initially did recognize all the NICs

Edit2: I found out that it is available for testing and not on the main website. Is it available as an image for flashing anywhere or will I have to compile it myself? If so, where do I start? I have never successfully compiled anything, so where would you recommend I start reading etc?

the nightly build server have the images for 159:

I have also tested core158 now and can confim the problem. Looks like a kernel/firmware problem in core158 which have updated linux firmware but still to older kernel…

I installed version 2.27 core159, the aarch64 version, and it did resolve my issue.

Thank you for your time and help :slight_smile:

Moving on to the configuration of the firewall :smiley: