Samba share through vpn

Hi ! I’m trying to get the integrated Samba working to share an external hard drive.

I created my share:
[Pancake]
path = /home/nobody/shared
writeable = yes
create mask = 0777
directory mask = 0777
public = yes

and the shared directory is non empty (and data is available to all, read/write).
I tried a lot of different parameters permutation to make it work but in the end I can not connect from my windows pc.

  • What am I supposed to type in the windows explorer to get to my share? The sharing between my old linux system works but not from the ipfire (installed on a pi3)
  • What is the recommended configuration?

The Pi is using openvpn and emits a wifi network. I want to connect to this network with my computer and access the share on the Pi.
I read a lot of stuff on samba but I don’t really get what’s going wrong.
I was also wondering if the firewall was an issue… Maybe some pointers in this direction. I have apparently no rules appearing in the firewall menu.

Here is an image of the GUI for configuring samba. (I modified some stuff to see if it would work but nothing changed anything significantly.

In your openvpn advanced server options, what do you have for DOMAIN and DNS?

Hi patafikss.

One question, have you checked the owner and permissions of the /home/nobody/shared folder?.

with: ls -la

Maybe in the Samba you have set the create mask and directory mask to 0777 but you don’t have access to the shared folder by owner / permissions.

With access \\(ip of ipfire), I should show you the share “Pancake” and be able to access it.

You will tell us.

Regards.

@pavlos this is the content of the file in /etc/dhcp/dhcp.conf.
I installed openvpn using the CLI and it looks like it works well, it looks like it’s not the configured on the GUI though.

ddns-update-style none;
authoritative;
subnet 172.17.100.0 netmask 255.255.255.0
{
        option subnet-mask 255.255.255.0;
        option domain-name "localdomain";
        option routers 172.17.100.50;
        option domain-name-servers 103.86.96.100, 103.86.99.100;
        range 172.17.100.100 172.17.100.125;
        default-lease-time 3600;
        max-lease-time 7200;
}

@roberto rights are fine, I used chmod 777 on the shared directory. Rights are: drwxrwxrwx

Which ip should I use? There three different IPs when I type hostname -I.
One starts by 192.168, the other by 172.17 and the last by 10.8
None of them give a satisfying result. I understood that one is RED one is GREEN and the last I don’t know. I’m not sure what that means though.

As I said, the Pi emits a network (B) on which I want to share using samba.
I wonder if the share is configured to be available on the network (A) that the Pi is connecting to (my box from my internet provider) but I didn’t really have much luck connecting to that either.

Here are some logs:
log.nmbd:

    [2019/11/09 03:55:48, 2] nmbd/nmbd_nameregister.c:193(wins_registration_timeout)
wins_registration_timeout: WINS server 0.0.0.0 timed out registering IP 172.17.100.50
[2019/11/09 03:55:48, 3] ../lib/util/util_net.c:70(interpret_string_addr_internal)
interpret_string_addr_internal: getaddrinfo failed for name Pancake [Name or service not known]
[2019/11/09 03:55:48, 3] ../lib/util/util_net.c:210(interpret_addr)
interpret_addr: Unknown host. Pancake
    [2019/11/09 03:42:02, 0] nmbd/nmbd_incomingrequests.c:213(process_name_registration_request)
    process_name_registration_request: unicast name registration request received for name HOME<1e> from IP 172.17.100.50 on subnet UNICAST_SUBNET. Error - should be sent to WINS server
    [2019/11/09 03:42:03, 0] nmbd/nmbd_workgroupdb.c:276(dump_workgroups)
    dump_workgroups()
    dump workgroup on subnet 172.17.100.50: netmask= 255.255.255.0:
    HOME(1) current master browser = UNKNOWN
    IPFIRE 40809a03 (Pi)
    [2019/11/09 03:42:03, 0] nmbd/nmbd_workgroupdb.c:276(dump_workgroups)
    dump_workgroups()
    dump workgroup on subnet UNICAST_SUBNET: netmask= 0.0.0.0:
    HOME(1) current master browser = UNKNOWN
    IPFIRE 40809a03 (Pi)
    [2019/11/09 03:42:03, 3] nmbd/nmbd_serverlistdb.c:397(write_browse_list)
    write_browse_list: Wrote browse list into file /var/lib/samba/browse.dat
    [2019/11/09 03:42:03, 3] param/loadparm.c:9624(lp_load_ex)
    lp_load_ex: refreshing parameters

These were obtained by searching for \192.168.0.42\Pancake or \192.168.0.42. I also tried with 192.168.1.42 (the “remote announce”) but no luck either

You have disabled samba for the OpenVPN interface.

Hi @arne_f,

Thank you for you answer, I suppose this means ‘google it like everyone sensible person’ so I’ll try to do that.

No. The answer mean that you should look at picture of your config and there is an area Interfaces where you can enable and disable Samba for OpenVpn which is set to off.

You’re right, I forgot to mention that this has no effect whatsoever.
I indeed tested to check this button but since I saw no change I reverted it. I tried again now, and I see no change either.
I suppose this is not an IPFire related problem and I should ask people from OpenVPN/Samba

Are you using a windows client? If yes try to disable the windows firewall if enabled. (By default windows firewall block SMB for other subnets than its own.)