Samba 4.13 Error

I just updated to ipfire 152.
I am getting this error for samba
nmbd Error - should be sent to WINS server

I found the solution on the web and it is:
There are two ways to solve this ‘problem’:

  1. You have an windows server, which runs wins
    You told all windows network systems, that this windows server ip
    address is fro wins. Depending on static or dhcp ip’s you have to
    manualy assign wins in tcp/ip properties, or chaneg dhcp config and
    do “ipconfig /renew” in a command windows.
    For the samba system you must add "wins server =

    man smb.conf:
    wins server (G)
    This specifies the IP address (or DNS name: IP
    address for preference) of the WINS server that
    nmbd(8)should register with. If you have a WINS
    server on your network then you should set this to
    the WINS server’s IP.

     		  You should point this at your WINS  server  if  you
     		  have a multi-subnetted network.
     		  NOTE.  You  need to set up Samba to point to a WINS
     		  server if you have multiple subnets and wish cross-
     		  subnet browsing to work correctly.
     		  See  the  documentation  file  BROWSING.txt  in the
     		  docs/ directory of your Samba source  distribution.
     		  Default: not enabled
     		  Example: wins server =
  2. You want run wins on samba server.
    Set “wins support = yes”
    man smb.conf:
    wins support (G)
    This boolean controls if the nmbd(8)process in
    Samba will act as a WINS server. You should not set
    this to true unless you have a multi-subnetted net?
    work and you wish a particular nmbd to be your WINS
    server. Note that you should NEVER set this to
    true on more than one machine in your network.

           Default: wins support = no

Yep! A simple wins support = yes and no messages were logged any more - thanxxx!

In my network samba works without the legacy “WINS” at all. And microsoft say that “WINS” should not used if it is not already deployed. because it has some serious security flaws.

Also keep in mind that such additional options should set in smb.conf.local to prevent from overwrite by the webinterface.

1 Like