RSS improvment feedback

I highly depend on RSS feeds to keep up with as much information/updates/patching-cycles as I need to. Over the last few weeks I’ve been trying to troubleshoot why the IPFire RSS feed hasn’t been updating for a few months. I did some testing and set up verbose logging on my preferred RSS reader so I was able to capture more information on the IPFire Blog update from last Friday. I’m still stuck. I don’t know why it isn’t updating. So I reached out for help to my preferred RSS reader community. The feedback received was that not having unique GUIDs might be the cause.

Can someone please take a look at the w3 validator on the feed and fix the errors?

It is the only item right now that I’ve got to go on as to why the RSS feed isn’t working for me.

I know this is minor, but I would really appreciate any assistance as I’d like to have this feed working again.

Thank you!

Hello! I use the Vienna app on the Mac and it works as it should. This post RSS improvment feedback is currently at the top of the RSS list.

What URL are you pointing at to pick up RSS? I am using:

I’m using the link on the blog:

The link you provided does validate but has errors. The link on the blog does not validate with its errors. That’s what I’m hoping someone can fix.

Thanks for the feedback! works as expected also. No errors.

Can you list the errors you are seeing with your RSS reader? Maybe a screenshot or log entries.

The short of it is that the reader parses the feed but only sees one entry (the announcement for Core 146). It seems the reader is ignoring the rest as bad data.

I know the feed “works” because I’ve tried other RSS readers. It is a problem with my preferred RSS reader. As I mentioned above, I reached out to that community first and the current feedback points to the fact that, according to the w3 standard, the feed isn’t valid (the validator link in my original post). It fails the check. Since the claim is that the reader adheres to the w3 standard, the hope is that if the feed is fixed properly then the reader will work again.

For comparison to one that passes the check:


I use Feedly as my News Aggregator and the IPFire news feed works fine.

I mentioned that it works in a few other readers. But I like the one I use and switching still doesn’t fix the problem that the feed doesn’t validate on the w3 standard. That’s what I’m asking for.


Minor invalidation on line 216 (author). If your aggregator is refusing to read the news entries coz of this error I’d be changing aggregators.

Not trying to be too rude, but did you even look at my first post? It’s failing on not having unique GUIDs. The link has the details.

I sure did… just like you I rely heavily on RSS feeds to stay current with “information/updates/patching-cycles” and other news items of interest that’s why I’ve been following this topic.

Two options the way I see things:

  1. The IPFire authors fix the XML feed so that it fully W3C validates and you continue to use your favourite RSS Aggregator - fingers crossed for you.

  2. The authors decide to leave the XML feed as it is and not fix it - in which case you need to find an alternative RSS Aggregator.

I have been running the free version of Feedly for well over a decade (since Google ditched theirs) and can recommend it - I also appreciate the fact its a cloud based aggregator.

1 Like

@stack - Please add a bug report to Bugzilla. That will get this issue the attention it deserves.

Here is information about Bugzilla:

Here is the Bugzilla system:

If you have any questions or need help with the Bugzilla system please ask.

Done. Thanks!

The updated feed works! Whoo! Thank you everyone!

1 Like