RPi4 wit RTC-Module DS3231

has someone made work the RTC-Module DS3231 on an RPi4 with IPFire?

The hardware is working fine with a “normal” Rasbian (I followed this guidance:
Echtzeituhr-Modul DS3231 sorgt für genaue Zeitangaben - Raspberry Pi Geek ).

I have the newest Core Update 160, but it seems that the module i2c-bcm2708 is missing on IPFire.
Any suggestions, how to get it work?
Thanks in advance.


meanwhile I had the idea to compile the missing kernel module myself. But ah:
Here How can i use self compiled kernel module I learned, that that is not possible.
Too bad, but on the other hand understandable.

Does that mean I have to wait until the module is integrated into the kernel at some point? Or does anyone have another idea?

Hi @m_maassen,

Welcome to the IPFire community.

In your linked thread in posts 9 and 15 it says that you can build it but you have to compile the whole kernel in the build and then you have to exchange the whole kernel in your IPFire, not just the required module due to a new signing key being created every time the build is carried out.

Thank You, I will try it.

In the mainline kernel the RPi I2C driver is called “I2C_BCM2835” and it is enabled as module.

But RTC’s are not working with modules out of the box. So all components for the RTC must compiled in or you have to write a script that load the needed modules and read the RTC later in the bootprocess.

Interim Report:
The initial problem was:
when booting, the difference between system time and real time was to big, that led to disfuncional DNS resolving:

Setting system clock...
Thu Jan  1 01:00:11 CET 1970
Warning! clock runs later than last log access. Check battery/rtc!
Sun Nov 14 20:27:41 CET 2021
Setting time on boot...
Error resolving 0.ipfire.pool.ntp.org: Name or service not known (-2)
Error resolving 1.ipfire.pool.ntp.org: Name or service not known (-2)

Not only getting time from the internet didn’t work, but also ipfire clients couldn’t resolve names.
After setting the time manually everything worked fine.
So my first thought was to spend the Pi4 an RTC-Module (costs 4,90 €).
But it wasn’t working out of the box. That’s why I opened this thread - and learned that I have to rebuild the entire kernel, something I have never done before.

In the meantime I found a simple workaround: I simply changed the entries 0|1.ipfire.pool.ntp.org by IP-adress of my router (Fritz!box), which is a ntp-server its own.
Now the ipfire on Pi4 can set the system time at boot without resolving DNS, and after setting the time the DNS resolving works fine.
So the initial problem is solved, but there is still the wish to get working the RTC module, but without pressure of time.

I run also into this problem.

Strange is that ping.ipfire.org can still resolved but pool.ntp.org not so our test for working dns will pass even if the time is wrong. I will change this with the next update…