RPi3 Model B 1.2 network issues with core update 160

Hi there,
I updated my RPi with the latest core update 160.
I use an external USB-LAN adapter (for the red interface) and the internal LAN of the RPi for the green interface.
For the green interface i configured DHCP, but this is not working with this core update 160:
I get no IP adresses at the connected devices.
With core update 158 everything works fine.

I tried to setup the system new more than once - without success.
I changed the RPi - the same story.
If I use a second external USB-LAN adapter for the green interface (and not using the internal LAN) it works and I get IP adresses at the connected devices.

Do you have any hints for locating the error?

Thanks for your help!

Hello Andi! Welcome to the IPFire Community!

Based on just this info I am guessing there is something wrong in the Step 5 - Network Setup GREEN section. So either here:


and/or here:


Can you run the Setup again and send screen shots of these screens?

Based on this comment I am guessing there is something wrong in this area:

Again sending a setup screen shot would be helpful.

It is difficult to figure out without more info…

For the short term and to make things easy, let’s focus on the first scenario:

Andi … usually red is DHCP (picking up an ip from your ISP) and green is static ( and also you define the range for green. Any hosts connected to green will get a DHCP address based on the green range.

Dear Paul and Jon,
thanks for your feedback - you’re absolutely right.
Red is working and gets the IP from my FritzBox.
Green I have configured exactly how Jon has shown in his screenshots above (except the End address in my configuration is the
When changing green from the external USB2LAN adapter to the internal LAN port, my connected devices get no IP adress (eg. from the RPi after rebooting. When switching back to the USB2LAN adapter (without changing any IP settings) the connected devices get an IP adress again.
So with the external USB2LAN adapter everything is working fine, only the internal LAN port makes trouble… and makes trouble on a second RPI too…

In Network > DHCP Server, is green enabled? have you defined a range?

Yes, the IP of the green interface is in both cases (with the internal LAN and the USB2LAN adapter) and the DCHP server range is from up to
And - again: with the additional USB2LAN adapter for green everything works fine only with the internal LAN for green the DHCP server is not working.

Andi … let me see if I understand your setup.

Scenario a)
FritzBox ---- pi ---- some laptop
pi runs ipfire 160, wan is dhcp, lan is Laptop should get an ip in the range .100-.199
Question: during setup which mac address did you assign to green (the internal rj45 of the pi or the mac of the usb2lan adapter)?

Scenario b)
FritzBox ------ laptop
Laptop gets a valid ip from FritzBox

Scenario a)
this is exactly my configuration
I assign the internal LAN for green and one USB2LAN adapter for red => DHCP server is not working on green.
If I add and assign another (a second) USB2LAN adapter for green => DHCP server is working on green.

Scenario b)
This configuration works fine.

I additionally checked the following: if I assign the red interface on the internal LAN and the green interface on the external USB2LAN, I get a DHCP adress from the Fritz for red and on green the DHCP server is working. Sounds strange for me, i thought may be there is a driver issue for the internal LAN with ipfire 160, but with this test I would say that is not the case…

I built your network and figured out a solution but … I don’t know why it works :slight_smile:

FritzBox – (red) – usb2lan dongle – pi – onboard rj45 (green).

I logged on to the pi console and added this line in /etc/sysconfig/rc.local dhclient -v ; exit 0

Now, when the pi reboots, after initialization it will run /etc/sysconfig/rc.local (you will see some error messages) but if you check processes, ps -ef | grep dhclient shows it is running. My laptop gets and I can access the WUI.

I will try to figure out why it works, maybe an issue with the onboard rj45? (you wrote that if you add another dongle for the green and bypass the onboard rj45, your laptop can connect). That tells me something is going on with the onboard rj45 configuration.

I hope this helps.

1 Like

Dear Paul,
Actually - it works now.
The dhclient was not running without the changes in the rc.local mentioned in your post.
But I prefer to switch the red interface to the internal LAN and my green interface to the external USB2LAN because if I start once again a new ipfire configuration from scratch with the “ipfire RPi image” in some weeks/month etc., I must not forget to do the change in the rc.local.

This is the configuration I will use from now on:
FritzBox - internal LAN (red) - pi - USB2LAN (green)
It was also my suspicion, that there is an issue with the internal LAN.
In version 158 everything worked fine.
So, thanks a lot for your support and I will try out the configuration again with the upcoming versions.

Andi, it is quite possible that if I flip my networks as you described, dhclient may not be needed. Booting the pi now to make changes . … (after a few reboots, pi is slow) … dhclient needs to run after boot.
Now, red is the onboard rj45 and green the usb2lan dongle.

1 Like

Sorry for my delays. I built up a RPi4B with CU 160 and all works as expected. DHCP on Green with the on-board ethernet port works as expected.

I built up an RPi3B with CU 159 and no DHCP on Green with the on-board ethernet port. Very odd!

Need to experiment a little more!

Internet → Cable Modem → USB-LAN adapter (red) → pi → pi ethernet (green) → my iMac

I tried it with a pi3b … I don’t have a pi4b. If others are using pi3b, it would be nice to know if they had to run dhclient so that green will offer ip’s.

In my experiments I used the Pi Model 3 B V1.2.
Other versions (except older ones) I don’t have for testing.

It is not worth testing the older ones. If devices are 32-bit then they will no longer be supported in a few months.

I just tried a RPi3B+ with CU 159 and that works as expected. DHCP on Green with the on-board ethernet port is A-OK.

I’d suggest adding a bugzilla report. And Andi, you get the honors since you found the bug!

Information to add a bug report in IPFire Bugzilla: