Reduce clock speed/power consumption on RPi4B?

Is there a addon to reduce clock speed/power consumption? My pi is getting 62°C hot… never got it that hot with rasperian. I only get the temperature in hw diagrams, no clock speed etc.

Also I wonder that there is not network information except red on the main page.

my RPi4B with only raspberry pi lite is running near 50ºC.

my RPi4B with IPFire CU 159 is running near 56ºC.

is your RPi4B in a case? Does it have a heatsink?

I know the RPi4B do run hot and there were many complaints when they first arrived. I don’t know if this will help but take a look at:

It may not work with a raspberry pi.

I looked up “under clocking”. You’ll need to do more research but I found stuff like this:

https://www.raspberrypi.org/forums/viewtopic.php?t=250167

I got an standard aluminium case with heatspreader on cpu, RAM und USB controller (all thermal glue).

1 Like

As far as I know this is for x86 CPUs only.

Hm I may be wrong: Cpufreq - linux-sunxi.org

Hi Jon,

I just installed the addon and was too lazy for the ssh interface and therefore looking for “clocking” but I can’t find it. Am I blind?

Cheers Terry

from what I read yesterday it doesn’t look like an RPi uses cpufreq. And under clocking seems to be frowned upon.

There are references to the RPi4B having the ability to auto-slow (under clock) when the CPU senses high temp. But I have no idea if this is done in software (i.e., Raspberry Lite/Desktop) or in firmware. And I don’t know if IPFire has anything as part of its software.

Sorry - this is beyond my skill set!
:exploding_head:

It did the same for me. Since it doesn’t work there is no WebGUI interface.

EDIT:
FYI - The command I used when cpufreq is installed was

cpufreq-info

The cpufreq-utils is availbale for am since core159.

The initskript will change the default governor from performance (without installed cpufreq-utils) to ondemand. So have you tested the temperatures after installing cpufreq-utils and a reboot?

for me it stay the same (maybe goes up a little)

The break in graph is the reboot.

Not sure if this helps but I see these messages with cpufreq-info:

[root@ipfireC159RPi4B2 ~]# cpufreq-info
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 4294.55 ms.
analyzing CPU 1:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 4294.55 ms.
analyzing CPU 2:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 4294.55 ms.
analyzing CPU 3:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 4294.55 ms.
[root@ipfireC159RPi4B2 ~]# 

and these messages with /etc/rc.d/init.d/cpufreq start:

[root@ipfireC159RPi4B2 ~]# /etc/rc.d/init.d/cpufreq start
Starting cpufreq... imx-cpufreq-dt 
Error setting new values. Common errors:
- Do you have proper administration rights? (super-user?)
- Is the governor you requested available and modprobed?
- Trying to set an invalid policy?
- Trying to set a specific frequency, but userspace governor is not available,
   for example because of hardware which cannot be set to a specific frequency
   or because the userspace governor isn't loaded?                                                                                            [ FAIL ]
[root@ipfireC159RPi4B2 ~]# 

Yes. It varries between 58 up to 62 degrees.

I get exactly the same.