Read-only system notice on cli

Recently i installed the 64bit version and restored the backup from a 32bit installation on the same hardware. Everything works fine. I tried to have a look on the graphs and it says that they are built for another architecture. I tried to run some commands to rescan the sensors and on the save command it says that it is a read-only system and it cannot save.

Sorry, can’t create /etc/sysconfig/lm_sensors (Read-only file system)in/sensors-detect line 7399, line 8.

Any ideas on how to overcome this?

Thanks in advance


Hi @fantomduck

Welcome to the ipfire community.

The following wiki link should help

1 Like

Thank you for the welcome and the reply. This is what i was trying to do and on every command i get this notice. that the system is read-only.

If the system has become read only then that suggests that something went wrong during the install.

My first suggestion is to reboot if you haven’t tried that already. Maybe the hiccough gets fixed when the system is restarted.

If you have already tried that or if it doesn’t work then my strong suggestion would be to do a fresh install. If the system is stuck being read only I believe it will be easier and quicker to do a re-install and restore than to try and find what is causing the read only problem and to correctly fix it.