Randomly selected websites hit DNS eror

Yesterday, having set up a new box to run IPFire (thanks for the advice on using a USB dongle for the green network interface), I plugged it in and all seemed to be OK - but then I tried to log on to the web site of one of the banks I use: halifax-online. After struggling for a while, Google Chrome gave up and displayed the error message DNS_PROBE_FINISHED_NXDOMAIN. The web sites for the two other banks which I use (Santander & TSB) worked fine. A few other web sites gave the same problem as halifax-online - including, ironically, community.ipfire.org, as I found when I tried to log on to report the problem and ask for advice. I was able to do a work-around to access the problematic web sites: I connected my PC to a wired network port on the back of the router. However this isolates me from the other devices on my home network: two networked printers, my wife’s PC, the wireless access point which gives coverage downstairs (the ISP’s router comes into my computer room upstairs) and others.

Can anyone suggest a way to solve this problem, please?

Thanks in advance


The only sollution for my is:

Configure TLS hostname with dns.google

And configure both dns of Google ( and with this TLS hostname and configure addon with TLS.

I don´t fight any more with this.

Good luck.

Hi @roberto, Thanks very much for the speedy reply - I did what you suggested, and it worked :slight_smile:
Best wishes