QoS Graph Colours

I followed the QoS guide and everything appears to be working perfectly…except for the RRD graphing colours. It states in the help that if you setup matching uplink/downlink classes, the graph colours will match but that doesn’t seem to be my case.

I tried deleting the class RRD files in /var/log/rrd and restarted the QoS service, but they regenerated with the same colour scheme

I had the same issue after some core update. Unfortunately I can not tell you what actually sorted out the problem, since I tried many things.
But AFAIR there was some error in the created settings-files at /var/ipfire/qos. Maybe it’s worth having a look there, too.

The graph colours are not part of RRD database, but are set by the program(s) calling rrdgraph().
It has to be checked whether the statement of equal colours for uplink and downlink classes holds. Without having looked into the sources, I think the colours are selected both in a sequential manner ( 1. colour → 1. class, 2. colour → 2.class, …; with classes in numerical order ).

class 201 should have no rule for the colors to match. See the “tip” section.

1 Like

BTW: I just tried. My colours are identical.

1 Like

The names of the traffic classes are used to assign matching colors.
For example, name both classes 102 and 202 “Gaming” and the colors will match. You don’t need to use placeholders.


@luani , thx for this clarification.
I’ve adjusted the wiki.


That worked perfectly, thank you!