Pushing more than one search-domain to DHCP clients


I am trying to push a second search-domain to my DHCP clients. As far as I have read about this, the ISC DHCP server 4.4 currently used in IPFire supports the option “domain-search”. This option is not included in the advanced options list though.

As a workaround I tried to use a user defined option with code 119. The ISC DHCP server expects data in the format “domain-list” (list of domain names, enclosed in double quotes and separated by commas) within this option, which IPFire does not recognize as a valid value type. I tried to use “string” instead and defined a search-domain different from “domain-name”, to get at least a second one. Though the option gets pushed to the clients, it gets pushed without value (“domain_search (dns_namelist): {}” on macOS). Clearly the server does not accept the wrong data format.

Is there a way, I could get this to work within the current release of IPFire without editing dhcpd.conf directly (and unpersistently)? If not, can this be integrated in a future release?


Hi @cmuenkel

Welcome to the IPFire community.

I don’t think so. It does look like a sequence of double quotes, quoted strings, comma separated is not in the allowed option data types.

The domain-search option could be put into the advanced options list fairly easily but the main dhcp.cgi code would need to be modified to accept that type of input.

I had a scan through the dhcp.cgi perl code but have not found where the data type is defined.

I would suggest that you raise the lack of this option as a bug in the IPFire bugzilla. That way the issue gets recorded and can be worked on when resources are available or someone wants to pick it up as a bug to work on.
Your IPFire People email address and password work as your login details for the IPFire Bugzilla.