Proxy problem after upgrade to core 155 - The proxy server is refusing connections

Hello,
I upgraded 2 machines from core 154 to core 155.
After the upgrade both machines have the same problem, clients cannot access the internet through the proxy, the browser says “The proxy server is refusing connections”.

If I go to the IPFire web gui, Advanced web proxy configuration and click Save and Restart then the proxy works normally and I need to do this after every reboot.

1 Like

Strange, I checked for you by rebooting my IPFire Pi and I am using non-transparent proxy on GREEN & BLUE, core 155, I do not have the issue that you do.

In saying that I think I only set my proxy up either as of 154 or 155 so it’s possible that it might be a legacy config item in squid config that I don’t have?

Hello
i have the same problem as @panosst
cordially

I just changed the proxy port in ipfire (default 800, changed to 8001), and it seems to fix the problem.

1 Like

Hi, i have the same problem with proxy not work after upgrade 155 and IPFire normaly start.
Manualy start later over GUI work proxy fine.
Systemprotokoll 03.04.2021
Shutdown normaly
squid[31301]: Squid Parent: squid-1 process 31303 exited with status 0
squid: squid shutdown time: 6 seconds
Auto restart everyday normaly
05:03:20 squid[4855]: Squid Parent: will start 1 kids
05:03:20 squid[4855]: Squid Parent: (squid-1) process 4863 started
05:03:20 squid[4855]: Squid Parent: squid-1 process 4863 exited with status 0
Start over GUI manuell
10:56:16 squid[18039]: Squid Parent: will start 1 kids
10:56:16 squid[18039]: Squid Parent: (squid-1) process 18042 started
and now work it.

Cache.log
2021/04/03 05:03:20| Created PID file (/var/run/squid.pid)
2021/04/03 05:03:20 kid1| Current Directory is /
2021/04/03 05:03:20 kid1| Creating missing swap directories
2021/04/03 05:03:20 kid1| No cache_dir stores are configured.
2021/04/03 05:03:20| Removing PID file (/var/run/squid.pid)

2021/04/03 10:56:16| Created PID file (/var/run/squid.pid)
2021/04/03 10:56:16 kid1| Current Directory is /srv/web/ipfire/cgi-bin
2021/04/03 10:56:16 kid1| Starting Squid Cache version 4.14 for x86_64-pc-linux-gnu…
2021/04/03 10:56:16 kid1| Service Name: squid
2021/04/03 10:56:16 kid1| Process ID 18054
2021/04/03 10:56:16 kid1| Process Roles: worker
2021/04/03 10:56:16 kid1| With 16384 file descriptors available
2021/04/03 10:56:16 kid1| Initializing IP Cache…

I have no idea.

I just changed the proxy port in ipfire (default 800, changed to 8001), and it seems to fix the problem.

On that note, I should mention I’m also not using the default port 800 which might be why I’m unaffected.

I am using non-transparent proxy on Green and I am using the default port 800. I have not seen any problems since I updated to Core Update 155.

I just rebooted and the Proxy Server was still running and working afterwards.

1 Like

I also have strange problems with my proxy after updating to 155. Changed the port to 8001 and that solved it, until today. changed it back to 800 and it works again. So maybe restarting the proxy fixes it and not setting a specific port nr.

I too have had the same thing happening at multiple locations. Each firewall after a reboot require a restart of the proxy or as ive tested even as little as clicking “clear cache” in the web gui resets the proxy to work on port 800.
I tested other sites which I have yet to reboot since the initial after update reboot and cache flush run fine until until they get rebooted of course, same goes for them with something as simple as clear cache, or restart proxy via the web gui.
so thats batting 1000 so far on all that updated to 155 using default port 800, 11 so far.

Please follow the guidance given in the linked post below for registering the problems you are experiencing as a bug.

Thanks that fixed it.

I still have the problem over port 800 after updating to 156. Do you have other experiences?

idem for me.
No solution.
Only reboot Squid/Proxy

I thought the problem should be fixed with update 156

Well that would have required someone having the problem to raise a bug as was suggested in post 10 of this thread.

I have had a look in bugzilla and there is no bug entry on this topic since 12th April.

The core devs are a small team of people and they are very busy. Things that are raised as formal bugs in bugzilla will get reviewed and if confirmed as an issue with IPFire will get assigned to be fixed.

2 Likes

Just a suggestion. You should use the internal count system not your own counting from the postings, because this can differ/change if someone deletes something and maybe leads to confusion. Iam pretty sure you mean post 11.

https://community.ipfire.org/t/proxy-problem-after-upgrade-to-core-155-the-proxy-server-is-refusing-connections/5020/11

1 Like

Since it is not only me with the problem I submited a bug report:
https://bugzilla.ipfire.org/show_bug.cgi?id=12623

1 Like

Hi to everyone,
i’m getting this issue after upgrade to 157.

Ipfire before was 155 and everything worked fine (squid service too).

Hi,
i have tried to enable log management in Proxy configuration and it works.

In my case (with 157) if that option is enabled, the proxy service start correctly with reboot.
Telnet gives me access on 800 port.

Hi Everyone, upgraded from Core154 to 158 i have the same problem that the proxy is refusing connections.
It started after Save and restart in the GUI. Log management is still ON.
I will follow the Bugzilla post.