Proxy and DNS with FF

Hi !

Im not shure if this a Problem of ipfire or Firefox.
I setup webproxy (i guess its correct )
When i use now in firefox in the proxy option “automatic recognition of network proxy” everything is working.
But when i put in the proxysettings manual ( port 3128) it seems that DNS is notworking => page not found and with direct input of ip adresses i get the page…
on Commandline i get DNS resolution.
Im really confused, because i remember it was working while ago…

Ciao Gerd

Port 3128 is for transparent, you do not need to set it in Firefox configuration .
Transparent should work, when you set it at IPFire proxy to active .

Port 800 you need to add at Firefox configuration, when you like run Firefox over IPFire proxy .


1 Like

Depends if you use default setup
proxy port in my case is 3128 and transparent 3129… (i do not use transparent at all)

Ciao Gerd

OK, i understand .

The IPFire eth IP is ?
Same is for Primary DNS set to at IPFire DHCP configuration ?

Maybe there is a BUG in the proxy script, that gets visual after you had changed the default ports to others ?
I suggest do a test :

Set back the ports at IPFire proxy to the defaults, Proxy-Port 800 and Transparent-Port 3128 .
“Save and Restart” proxy .

Now configure Firefox, to use proxy port 800
Manual Proxy-Configuration Port 800
Use proxy also for FTP and HTTPS (set to enable)

DNS over HTTPS enable (set to disable)

Close Firefox and restart after a while, just to be sure .

Do that now works ?

Hi !
Yes .254 is ipfire and DNS in DHCP Config.
I will test you suggestion @weekend, but i’m shure thats not the problem because, when i use autoconfiguration in firefox (wpad.domain.tld is also right configured) it works… in my home network i’m still fine autoconfig, but when i’m external behind a firewall i have use manual proxy setting to bypass the firewall (im connected via VPN)
But as i told you my setup worked for many years and during on aof the updates since january it fails.
But i will check at the weekend…

Ciao Gerd