Proxy Accounting doesn’t work

Hi guys, I setup Proxy Accounting, it show me that is alive but I don’t receive any measurements. What should I do?

Thank you!

If I remember correctly, you have to check “Log enabled” for proxy accounting operation .



It is enable but is not Transparent on Green. I read in Proxy Acc. that the option should be unchecked.

Have you defined a provider and a customer definition in the Address Management tab and specified the IP’s to be grouped for a provider/customer combination in the Billing Groups tab?

Yes. A provider, a consumer, everything

If you select the WUI menu Logs - Proxy Logs and select All for the day and then press Update do you see proxy traffic being listed in the log.

If yes, then if you select the Source IP drop down box which has ALL by default do you see a list of IP’s that include the ones that you have specified in the Proxy Accounting setup?

If you got to Logs - Proxy Reports and select the time period as 1st April to 3 April and then press create report you should get a new report after a short period in the table on that page. If you then select that new report and press the view button then towards the end of that report you should find a section like the following screen shot.


The table should consist of the host names of the computers that have been accessing via the proxy. In my case the same two computers have accessed as are defined in the Proxy Accounting and you can see that one has requested download of 8453M and the other 41M and this matches with what I have in my proxy accounting table.

Do you see your defined host IP’s in the Proxy Report on your system.


I cannot update field IP from Group Billing…Doesn’t allow me to write there…
LE- No report shows me on Proxy Logs…
LE2- Seems that everything is active but no Logs at all…

Reading the wiki this field should get automatically populated by IP’s available from your proxy logging. You then select the fields of interest to make a billing group.

If this box is empty the wiki says this is because the addon has not collected enough data yet or the proxy or proxy logging is disabled.

If your Proxy Log is not showing anything this is also indicating that the proxy logging has not been enabled in the daemon or the proxy is not enabled.

If you checked the box as shown by @tphz in Post 2 above did you also press the Save and Restart button or only the Save button.
Typically I always press the Save and Restart to be sure that the proxy daemon has been updated with any changed settings.
You also need to have the Proxy enabled on Green and or Enabled on Blue checked and then Save and Restart pressed.
The web proxy should show as running on the services table on the WUI menu Status - Services page.

Before setting up anything on Proxy Accounting you need to get entries being shown in the Proxy Logs table as shown in this screenshot.

This is the data that the Proxy Accounting addon uses to create the graphs etc.


Proxy logs is ok now. I restart WebProxy. I will wait for ProxyAccount to colect more data because I still cannot complete Billing groups. Still dont have a list with IPs.

1 Like

But in your Proxy Log list that you show you do have IP’s listed to the left, correct? If yes then it should just be a bit of time to collect sufficient data.


It shows IPs in the left. I will wait to populate database…

The update period is 1 hour, FYI.
To be precise, the update process is run by fcron.hourly.


It’s alive. Thank you all for your support!


Check on log enabled