Problem with typing quotes in forum

Hello Community,

when writing posts I’m having problems with typing quotes here in the forum.

When I type one quote it is still ok:

echo "ipfire rules

As soon as I enter the closing one both quotes change in the output:

echo “ipfire rules”

Problem is, that when users copy this to e.g. ssh, the command will not work. Is this a global problem in this forum?

I don’t believe it is related to the forum. Look for something called smart quotes on the computer.

On my Mac smart quotes are in System Preferences > Keyboard, then Text tab

I don’t know where it is stored on a Windows PC…

Hello Jon,

thank you for your answer. Indeed I used a Mac but smart quoting is off. I also have this behaviour on Android. I am posting this reply from my mobile now with Android and Firefox.

cat "Hello World
cat “Hello World”

Could you try to reproduce it in a reply?

echo “is it ok?”
Just a try on Windows.

echo “no it’s not”
echo "its's only ok when you use preformatted text tag"

Maybe there is a global configuration option on the server side for this?

I can only see correct quotes. :wink:
Hadn’t a problem to type them in my post above, too.

Funny, so it’s a client Problem then?

Screenshot from Mac with Firefox, same with Safari, same on Firefox with Android:

Looking into the HTML source the mistake is in there:

echo "ipfire rules As soon as I enter the closing one both quotes change in the output: echo “ipfire rules”

<p>echo “is it ok?”<br>

Looking at this link it seems like it is a “Feature” of the markdown library in Discourse.
For code pieces this is definitly a very bad option but it looks like it can be deactivated.

Sorry, didn’t get the problem yet.
I can only see “correct quotes” of ‘both types’ , even when “‘mixing’” ‘“them”’

Look at the Screenshot. The regular straight double quotes change into “curly quotes” aka opening double quote and closing double quote.

This is a problem for code parts. Copy the 2 commands and execute the 2 examples in a terminal and you see the difference;

echo “hello”
echo "hello"

ok. Now I understand.
Didn’t see the “difference”. :wink:

Thus it is surely a problem of the forum SW/config.

1 Like

Thanks for the feedback. So it seems like a global issue that should be fixed, as all code blocks containing quotes will not work this way:

cat “/var/log/system.log” #will not work

Workaround for now: Use preformatted text tag:

cat "/var/log/system.log" #will work

This is a code block:

cat "Hello World
cat "hello world"

and this is a block quote:

cat "Hello world
cat “hello world”

Ahh now I see what you see!

EDIT: In code block it looks as expected. And in block quote it uses (switches) to smart quotes. Interesting, but I am not sure it is wrong.

Since you are typing cat "hello world" you probably want to be in code blocks (three back ticks before and three back ticks after)

1 Like

Thanks Jon for your input.

OK code block and preformatted text works as expected:
```echo "hello"``` :arrow_right: echo "hello"
`echo "hello"` :arrow_right: echo "hello"

Regular text and quote don’t work.
echo "hello" :arrow_right: echo “hello”
>echo "hello" :arrow_right:

echo “hello”

Still quite “annoying” for a technical forum. :wink:

1 Like

I’ll say it is annoying. Turn of the dumb auto correct, where ever it is. Let us do our own corrections.

1 Like