Problem with DNS?

Windows 7 x64 - latest version of released Ipfire.

For some time I have had a problem accessing some sites - Firefox complains that it cannot find them.

I can get around it by altering the adapter settings on the windows machine so the the DNS uses - thus bypassing Ipfire.

Ipfire is set to use the ISP DNS whitch resolves to - I have been through the Ipfire settings many times but I can see nothing that should cause this for sites such as “” everything else seems OK

What have I mucked up ?? Any suggestions as to how I might fix this are most welcome.

Many ISP’s filter the DNS replies they provide and track what is being asked for.

If you want to use I would suggest to disable the ISP DNS on the DNS WUI page and add in or look through the IPFire Wiki page on DNS servers and add in 4 or 5 so that you always have DNS available if one should have a hiccup, which can occasionally occur.

You can also use TLS for the DNS connection so that your DNS traffic is encrypted and can’t be viewed by anyone on route. Of course the DNS server you use will know what you are searching for but that is where you have to review their privacy and logging rules to see if they meet your expectations.

I would also read these IPFire Blog posts about DNS.


Adolf was quicker than me :slight_smile:

But I just suggest the same. Use one or more DNS servers of your own choice - and be amazed.

Best regards


Hmmm, that seems to fix it — Thanks all



Another case to link Documentation of IPFire. :wink:


I was wrong - it has NOT fixed it - it seemed to for a while but the problem is back again, I suspect that the windoze dns cache was fooling me :frowning:
I cannot ping and some other sites even from the ipfire console, though many other sites seem OK.

Further info …
I did a clean install of IPFire (latest release) and did a basic setup specifying NOT to use the ISP’s DNS addresses and adding abd and I see identical behaviour! I cannot access certain websites (eg

I have also tried - same.

At first I suspected the ISP — but if I set my windoze system to not use the IPFire DNS but directly use it works ! It just bypasses IPFire.

So - I have no idea what to try next !!

Not solved

Any errors on the IPF DNS panel or in System Logs?

Perhaps share a screenshot of your IPF DNS panel.

1 Like

@David: Other question. What kind of machine you are running ipfire on? VM or bare metal?

I’m running ipfire on two bare metal machines, one jetway NU591 intel N3160 based and one NanoPi R4S, both using Lightning Wire Labs DNS without any trouble.

[root@ipfire ~]# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=59 time=13.6 ms

I tried Cloudflare DNS ( on my jetway, too. With it, pings some 2ms slower than with Lightning Wire Labs DNS, probably because it is located somewhere overseas, whereas LWL DNS is only couple of miles away, but works as well.

So I guess, there may be still some misunderstanding between your ipfire and your DSL modem/router.

Best regards

It is running on a “bare metal” system.

I notice that both and show a failure on reverse lookup but ald “Working”

Screen shot requested is attached

BTW I am very unfamiliar with linux and have no idea how to look for errors in the logs. If you tell me how I will zip them up and attach them.

Just to remind all a minimalist clean install with the same DNS settings behaves the same. What the devil am I doing wrong ??

The fact that you have the Reverse DNS Lookup (rDNS) failing indicates that there is still something wrong with the path out to the DNS server.

I just set up and with udp on my system and got the following.

The rDNS should show as in my screenshot.

Do you get the green OK if you press the Check DNS Servers button.

If the message is not OK or the colour is not green then hold your mouse pointer over the status and after a second or so there will be a popup box giving a short message about the status.

What response do you get when you run the ping command.

Here is what I am getting:-

ping -c4
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=252 time=5.02 ms
64 bytes from ( icmp_seq=2 ttl=252 time=5.17 ms
64 bytes from ( icmp_seq=3 ttl=252 time=5.26 ms
64 bytes from ( icmp_seq=4 ttl=252 time=5.15 ms

--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 5.022/5.149/5.255/0.083 ms
1 Like

See below …

No, it’s always Working but rDNS shows as failing Yes Pinging always returns “not found” both from Windoze and the IPFire console.

This is not clear to me.

The only status that ever shows Working in green is the one at the top left hand side of the DNS server WUI page. This is the status of the IPFire unbound DNS server.

The question I asked is what the status of the two external dns servers you had selected was as circled in this image.

The status shown in this black circled area is shown after you have pressed the button labelled Check DNS Servers.
This status is never shown as Working. It shows up as OK in green if the individual DNS servers you are using are fully functioning.

When you say that
“it’s always Working”
do you mean that the status for and the status for both show OK in green?

Can you also copy and past the results of running this command from the console


Can you describe your setup?

Is it a modem going to IPFire?
Is it a router going to IPFire?
Is the router in bridge mode / modem mode?
Multiple routers etc?

Sometimes a picture can help :slight_smile:

Since your screenshot shows as your ISP DNS then I suspect you have a router going to IPFire.


in you Domain Name System setup.
Do you have the DNSr name in the WUI for each entry?
see examples.
You need the TLS Hostname.

He is using UDP so there is no need to put the TLS hostname entry in.

You should get the rDNS answer back and that he is not getting.

With the same dns servers i am getting the rDNS of shown on my dns wui page.

I think that before we try and get him to use DoT we need to find why the simple UDP is not working properly.


They are always a green “OK”

Okay, then please show us a screenshot of your DHCP WUI Page for the Green section.

It would still be good to also see the output from the

1 Like

I am not using TLS.

?GOOD? news (or just confusing?) I seem to have fixed the problem by using a UK DNS server ( ) I get the rDNS name and I can access!

Why causes me problems via IPFire but NOT if I force the windows machine adapter to use directly (rather than use the IPFire DHCP provided value of I have no idea - it all goes via the same cable and router and the same ISP).

I can only think that there is a timing issue in there somewhere or IPFire is furkling in there somewhere.