Problem with Azure serial console and root password

Hi all,

I am trying to create a simple RED+GREEN firewall in Azure for labs.
I successfully did long time ago with 2.23.x86_64-full-core133, but now it seems impossible to get root access over serial console.
I tried both the one that worked for me in the past (2.23) and latest 2.27, same result.

These are the steps I’m using:

  • Create Hyper-V VM.
  • Add line at the end of /etc/inittab for ttyS0, so Azure Serial Console connects fine. I didn’t need to do this step in the past.
  • Upload VHD to storage account.
  • Create a managed disk out of the VHD.
  • Create a VM from the managed disk.

I can connect to the green interface from another VM and configure firewall.
The problem is that when trying to log through serial console, the password for root is not accepted anymore, and returns “login incorrect”.

The same behavior occurs creating the VM with an unmanaged disk from the blob storage.

Any ideas?

I also had to add ttyS0 to /etc/securetty


Strange? Normal ttyS0 should be already in /etc/securetty in the IPFire image.;a=blob;f=config/etc/securetty;h=9a6a9fd30e841539a99fb191d3fa9b44f7ed5c26

If you add console=ttyS0,[baudrate-config] to kernel cmdline at first boot this should auto added to all needed files. (grub,getty usw.)

For some reason, at least installing in Hyper-V in Windows 10 21H1 (build 1466), the console=ttyS0,115200 switch freezes the boot into black screen.
Booting without any switch works fine and setup finishes, but /etc/securetty contains:

PS: I was mostly needing serial console to reassign NICs when booting in Azure, but now IPFire is doing a great job configuring NICs in Azure, so not really needed unless for emergency access (i.e. locked out SSH/Web access).