Problem getting red to connect

I new to the community
Thank you ipfire for this great product :two_hearts:

I been using ipfire before and now I wish start use it again but got this unbound dhcp leases error when booting
There seems to be a fix to this as I read other post here too :slight_smile:
But I’m not a script guy so I was wondering if someone would be so kind and help me in the right direction
The problem for me is how I actually add the needed lines into the script

Thank in advance

Hallo @danny

Welcome to the IPFire community.

You shouldn’t need to put any additional lines into any script to make it work.

Can you show us the error you see when you are booting.
Can you also confirm which Core Update version you are working with.


Welcome to the community.

Is this a new installation? Can you post the exact error message you are getting? Keep in mind that details are crucial for troubleshooting. More you give details, higher the chance you will be helped to find the solution.


I got the error to go away by burning a new imig in DD mod at Rufus

I’m currently on the latest version core 174
But still no connection to my cable modem HGA20R-02
The modem is in DMZ mod with server IP

On Red I put static and also include gateway from isp
still not connecting…
I try different IP on red no difference
Maybe there is something wrong with my modem? Ore maybe some one see what I do wrong ? Any help very much appreciate

Just noticed in boot text.

Error: ipv4: Fib table does not exist


Error resolving name or service not know (-2)

Error resolving name or service not know (-2)

Is this normal?

I have changed the title of your thread as the first issue has just gone away with no info and the new issue is no longer to do with unbound.

When you have a new issue the preference in the forum is that this is put into a new thread so that you don’t end up with one thread with 4 or 5 different problems in it.

1 Like


I did give info to how I got it to go away sir

I got the error to go away by burning a new imig in DD mod at Rufus

You have used the same IP for red as is being used by your modem dmz. You musn’t do that.

Unless your ISP has provided you with a specific static IP then the simplest option is to use the dhcp option on red. The dhcp protocol will then obtain the appropriate IP and Gateway info from your ISP via the modem.

1 Like

This is a standard error from a package called ifconfig2 that we can’t stop being shown. IPFire does not use the FIB table but as it is a default table then the fact that it has not been used is flagged up.

This is because you don’t have a connection to the internet via the red interface, therefore the unbound dns system is not able to resolve the ipfire ntp url’s

1 Like

Thank you Adolf

I put red to dhcp as you advise and I got ip for red now but still no ping to outside

I connect my laptop to the green I get IP but still no internet?

Any ide?

Starting dhcpcd on the red0 interface. FAIL ??

If you try

ping -c4
do you get any response like the following:-
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=56 time=26.4 ms
64 bytes from icmp_seq=2 ttl=56 time=26.5 ms
64 bytes from icmp_seq=3 ttl=56 time=26.6 ms
64 bytes from icmp_seq=4 ttl=56 time=26.6 ms

— ping statistics —
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 26.398/26.523/26.595/0.078 ms

or is it similar to

PING ( 56(84) bytes of data.
From 81.3.27.xx icmp_seq=1 Destination Host Unreachable
From 81.3.27.xx icmp_seq=2 Destination Host Unreachable
From 81.3.27.xx icmp_seq=3 Destination Host Unreachable
From 81.3.27.xx icmp_seq=4 Destination Host Unreachable

— ping statistics —
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3052ms

If it is the second then that indicates that you still have a problem with the connection to the internet.

In that case you would need to look at the logs for the red connection.

Go to the WUI menu Logs - System Logs and select RED in the dropdown box labelled Section: and then press the Update button.

You should then get all the logs for the connection to the ISP and that should give some indication for what is going wrong.


Can I go to WUI when I still not get connected?

Changing to DHCP did not fix my problem unfortunately

Yes. You already mentioned that you had connected a laptop to green and got an IP, so you should be able to access the WUI from that laptop, following the info in the Wiki.

1 Like

After follow your advice I got a IP but still can’t establish connect after reboot of ipfire connection get lost and no IP

So your solution isn’t stable and I still have no internet connection from red ore green unfortunately.

Any one please

Are there some one that has experiences with config the ISP modem in DMZ with ipfire ?

My modem not provide bridge mode so DMZ is the second best right and the only way I believe…

I would agree.

One of the first thing you need to do is setup your Domain Name System
Or you will have problems

1 Like

Thanks Shaun I will give it a try :slightly_smiling_face:

My solution
Contact ISP and get a router that supports bridge mod

Thanks for all the suggestions

1 Like

“ipefire” → ipfire?