Problem downloading ISO image (error 429)

Hello, folks,

I just tried (5mn ago) to download the torrent version of CU178 ISO version and it made my transmission (appli) crash after a few minutes (just a few Ko downloaded) … so, I tried downloading the xz image, but I got a:
##### Error 429
# oops, something went wrong
And the title of the page, in FF, is “Too many requests”, so, I only have to be patient and try later ?
Nevertheless, the “Flash” image seems to be OK (less people interested ?).

[downloading many times many versions, that’s the first time I get these errors]

Erf, looking in the downloading rep for the “.torrent” file, I saw that the xz image is downloading (by FF), so even if “too much requests”, downloading happens in the background, cool !
However I keep asking why (and how) downloading the torrent image made my transmission application crashing !?
I use it since… it exists (20 years ?) and it never happens, transmission never segfault.

Sorry bothering you for almost nothing.

Best regards,

It’s me again ! :wink:

for the “transmission bug”, it seems that it’s linked to a translation problem in “fr_FR.utf8”
systems (like mine), there is some bug reports here and there.
It seems to happen only with some specifics torrent file (as IPFire’s ISO torrent one), the error message in transmission is:

*** invalid %N$ use detected ***
[“Abandon” == “Leaving” so, it’s not a segmentation fault as I first thought]

One solution is to re-compile transmission without “nls” flag, or – more simple – just load (in a term, of course) transmission with ‘LANG=C transmission-gtk’ (or ‘transmission-qt’, of course, depending which version you use (… even if I don’t know if it happens when transmission is compiled against QT library)); with the ‘C’ locale, it’s OK.

I explain all that because I have a day-use of transmission and never met this bug, it is only related with the content of some torrent files of which IPFire’s one is part of, so for french guys in the same situation this is a sort of workaround.

And for IPFire people (devs) maybe it exists a way to generate torrent files that work on french systems using transmission (I get thousand of, here … it’s the first time a torrent file do this).

@IPFire people: Maybe there’s a better place for my post / thread, do what you think is best with it.
(maybe renaming (at least this one) with sort of “Transmission bug with IPFire ISO image torrent file on FR systems” ?)

1 Like

this sounds to me something that should go to a bug report. At least the developers would be aware of this issue. What I do not understand is in which way the torrent would trigger the “abandonment issue” of transmission? Using a German locale? It’s a German/France issue :grin:?

Yes, of course, as I said, there is already some (on gentoo’s bugzilla).

Héhé… metoo ! :wink:
I think to really understand, one must “put her nose” in the torrent file, what I don’t want to spend time to.
That’s why I ask to the IPFire’s devs, I don’t know what soft they produce their torrent files with, nor how they do.
A torrent file is not a text file, even if some parts are readable strings.

But, I do not think of a transmission bug, rather an “IPFire’s torrent file bug”.

that’s why I would report it in IPFire bugzilla.


sorry cfusco, I didn’t understand you, it seems … :confused:

I’m trying to open the torrent file, but I’ll stop as I have other things to do, I’ve found ‘btcheck’, ‘btfs’, ‘buildtorrent’ and ‘mktorrent’ on my debian, trying it.

I’ll send the bug report asap, thx.

best regards.