PPOE WAN Connection Block of IP's no Alias Menu

Hi community.

First thanks for IPFire it’s been grate.
I just have one issue now since getting a block of 5 WAN IP’s from my provider and that is I can’t seem to use them when connecting via PPOE. After googling I have found instructions that say the menu will only appear when the WAN is set to static. So dose this mean I just wont be able to use them in IPFire with a PPOE connection or have I missed something?

Thanks in advance for any info, suggestions or pointing in the right direction.

Hello @kingsize Welcome to our community. Using public IPs aliases can be done with the PPOE interface, however the author’s tutorial (@mhgschmidt ) is not available at the moment. I read the tutorial and understood the general procedure but I do not remember anything right now. If you cannot get from a private message to @mhgschmidt a copy of the text, maybe @bbitsch can help you out as he also read the tutorial and probably understood better than I did how it worked. Maybe with his help you can re-discover the procedure.

maybe one of these documents:


now the web page is again accessible. Before it was down.

I pointed to the public side vs the original link pointing to something else (maybe local side)


Definitely my brain is in short circuit mode today. I can’t believe you had to spell it out for me! Thanks @jon I appreciate the patience.

1 Like

@jon, should we add this work around in the Alias wiki page? I would imagine it would be useful for IPFire users. Of course giving credit to @mhgschmidt for this cool hack he came up with.

Let’s see if @mhgschmidt or @kingsize, or someone, can confirms it works. (I do not have PPPoE to test)

If so, then yes, please feel free to add!

@mhgschmidt has claimed in several messages that this hack has worked very well in his system. It’s a corner case because to test it we need both multiple fixed IPs and a PPOE interface. If @kingsize would be so kind to confirm that it works (or not), we could make it part of the wiki and this would be useful to the next user searching for this feature. I would also link the original file and give proper credit to the author.

1 Like

Hi all

Sorry for the delay, I’m sorry but I had a quick dip in OPNSense :grimacing: It was my original choice when I moved from a Nethserver 7 setup due to its dual WAN features.
Any how it was short lived for now as I’m “still” just not clever enough to build every rule from scratch :melting_face:

Right so I’m back on IPFire currently 176 as that was the install media I had lying about and I wanted just to test before updating which I will do soon.

I can confirm that the workaround dose indeed work. I have so far used two of my WAN address and successfully NAT’ed to two different web servers.

My set up is possibly a little different than that in the how to due to my ISP BT.
My IPFire (or OPNSense) gets a dynamic IP address each connect (VERY F*&KING ANOYING) so I’m not sure yet if I’m going to be able to continue to use IPFire for VPN Meh!

I have a block of 5 usable IP’s, these are some how attached to this dynamic connection. It’s a /29 but I’m fairly sure I can’t use 6 of the IP’s so I stopped at 5 when creating the necessary config files.

But yes it works thank you to all


Updated the wiki to link to @mhgschmidt tutorial.

1 Like