Port Forwarding looks OK but not able to access website

RED and GREEN are my private network. Log suggest that FORWARDING is ok, but somehow I am not able to see response in RED network. I am missing something basic here?

Below is how

  1. my setup looks like and logs are for accessing GREEN website from RED
  2. my firewall PORT Forwarding rule look like:

Other Debug Info:

  1. on GREEN network: cURL >>>> returns “hello world!”.
  2. [PROBLEM] on RED network: cURL >>>> Failed to connect port 80: Operation timed out — after port forwarding, I am expecting machine in RED n/w also gives me response same as above from machine in GREEN n/w
  3. on RED network: ping >>>> OK. 4 packets transmitted. 4 packets received. 0% packet loss.

I think you need External Port (NAT) filled in.

as suggested, I tried with below changes, but still not able to access from RED:

  1. in firewall rule, updated External Port (NAT) to 54000
  2. i have change website port from default(80) to 7000
  3. i opened this port 7000 on hosted linux machine (
  4. to make sure website still working, i tested it’s from IPFire machine([GREEN]/[RED]). I used curl, and I can see response
  5. still not able to access website

Should work
Try standard network RED.

didn’t work either. thanks @hvacguy anyways. do I have to open port manually? Can below info be helpful:

From GREEN n/w


Starting Nmap 7.80 ( https://nmap.org ) at 2021-02-06 20:35 CST
Nmap scan report for wall (
Host is up (0.00020s latency).
rDNS record for ****
Not shown: 996 closed ports
22/tcp open ssh
53/tcp open domain
81/tcp open hosts2-ns
444/tcp open snpp

form RED n/w


Starting Nmap 7.80 ( https://nmap.org ) at 2021-02-06 20:52 CST
Note: Host seems down. If it is really up, but blocking our ping probes, try -Pn
Nmap done: 1 IP address (0 hosts up) scanned in 3.04 seconds


PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=3.33 ms
64 bytes from icmp_seq=2 ttl=64 time=3.03 ms
— ping statistics —
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 3.033/3.183/3.333/0.150 ms