Port forwarding doesn't work core 162

Hi all,

Some time ago, with core 161 I tested a mail server in my network and port forwarding was working well for all the port that it needed.

Now with core 162 I can not forward port 80, testing with nginx server in Xubuntu 20.04. I asked to my isp if they were using cg-nat and the answer was No. But after some reboots of ipfire to change the public IP (sometimes this fix the problem with my isp) the problem remains.

If they don’t use cg-nat, what I’m doing wrong?


This is my port forwarding setup

Try and make a connection to your web server on from the internet and then look in the logs to see what sort of messages you got. This will indicate if the connection got through to IPFire and will also tell you if IPFire dropped it or passed it on to the web server.

Thanks Adolf, I’m going to try what you say and I’ll post the results.

I can’t see anything in logs, although I didn’t check deeply.

The fact is that I’ve tested with a linksys router (very simple router) and the port forwarding works as expected. That discard isp cg-nat.

This is linksys router tested with grc.com

But coming back to ipfire the result is the same, it doesn’t work.

I don’t know what could be the problem. I need to resolve this because I’m planning to install security cameras, and I need to access them from internet.

If you use grc.com when you have ipfire in place what do you get? Edit: Ignore this question. I missed the screenshot first look through.

If it is nothing then you must have another rule somewhere blocking it.

Do you have location block and/or IPS running. They might be blocking things, depending what you have set up. If they are running turn them off and try again.

Have you put any rules into firewall.local?

You have absolutely all the reason Adolf that is a thing that I ever forget.

I have disabled location block and now the port is open. Sorry.

Thank you very much for your help and time.

I can not edit the title of the original post to put “solved”…

At the bottom of each post are three dots. One of those is a tick in a box. If you select that in the post you want to indicate as the solution it will indicate that and also put the same mark at the top of the thread.

Thank you very much again adolf.