Please change the Backup-Script back


I always (Daily) make Backups from my Firewall and copy the .ipf-Files to a NAS.
But since one Core-Update the Name of the BackupFiles will create with “:” in the Time-String.

Could the Variable “NOW=”$date “+%Y-%m-%d-%H:%M” in the file “” change back to an Copy-friendly format?
I have changes it to “NOW=”$date “+%Y-%m-%d-%H%M” but with an update it could be changed back.


Those issues are posted best in bugzilla. Your account of is useable there also.
A topic in bugzilla is more “visible” to the core devs.


Ok Thank you.

I have backups from IPFire back to January of 2020 which are using the : in the time string.

I checked back in ipfire git and the NOW variable in occurred in the first instance with Core Update 125 in Nov 2018. The variable used a : in that first occurrence, so it has always used a : in the time string.

I think you need to look for a different cause for the problem you are experiencing with your backups.

I have added this information into the bug (#12547).

1 Like

Hello Adolf Belka,

I dont know when this problem exactly occurred. (We use ipfire a little bit longer than 2 years) :wink:
But i found out that the NOW is the reason and correct it again when it was changed by an Update.

I think it isnt a good idea to use “:” in a filename. What do you think?

Hallo Helmut Pfeiffer,

I have gone back to Core Update 124 and looked at how the filename was defined then. It was defined as:-


Then with Core Update 125 on 17th Nov 2018 it changed to the use of the NOW variable and was defined from then as:-


So the use of the : has been there for just over two years and 27 Core Updates.

I don’t see it as a problem to have a : in the filename, at least as far as Linux goes. In Linux the use of : in the file name is permitted and IPFire is Linux based (LFS).

If you need to store the file on another system, such as a NAS that is not based on Linux and has a problem with the colon then I would recommend to modify your script to take the filename on IPFire and replace/remove the colon using something like sed before saving the file on your NAS.

1 Like

How do you copy the files?
Using Windows, which doesn’t allow ‘:’ in a filename, I do not have any problems.
Downloading from the WUI with Firefox replaces the colon by a space.
Using WinSCP the colon is replaced by %3A.

Hello Adolf Belka,

Thanks for your Information.
I copy the files from another Linux-Server.
The Backup will made by this script on the Firewall.

Then my Copy-Server is daily copiing the files to a NAS.
The Problem was not to store it on the NAS, rather the scp-command in my Copy-Shellscript i do copy “.ipf" and ".iso”

But so i will look for another solution in my script.


Hallo Helmut Pfeiffer,
I do something similar with my system. I run the IPFire on a weekly basis but I then use the Bacula addon to backup the .ipf files and some other files to my Bacula Storage Daemon on another server I run.

You say the problem occurs when you do the scp command. Do you run that command from IPFire or from the NAS.
I have also used the scp command to copy the .ipf files from IPFire to my File Server but I run the command on my File Server. I have tried this with both *.ipf and also with the whole filename with the colon in place and in both cases the scp command successfully copied the file with no problems.

I would expect that what you have described should work with the colon in the filename.
If you can say what the specific scp command is and whether it is run on IPFire or not, I could try and duplicate the same command on my systems and see if I can replicate what you are finding.

Hello Adolf,
I run this scp commands on a extra LinuxServer who is a Backup-Server which do a lots of Backupjobs:
scp -P 222 -C root@[IP-Adress]:/var/tmp/backupiso/.iso /mnt/firewalls/1
scp -P 222 -C root@[IP-Adress]:/var/ipfire/backup/
.ipf /mnt/firewalls/1

The OS is a CentOS:
The Bashversion ist 4.1.2(2)-release


@Adolf Belka:

Do you use fcron to create backups using ?

If so, would you care to share your script(s)?

Thank you,

Hi Helmut,

If I follow your commands as you have them then I get a “No such File or Directory” message. However that is also the case if I have filenames without a colon, as I tried that as well.

I am not sure why you are using just .ipf for your file definition. That is what my system has a problem with. If I use *.ipf then everything works fine, also with a colon.

I tried with and without the -C. No difference found except that with -C the transfer was much slower.

So my working command was:-
scp -P 222 root@[IP-Adress]:/var/ipfire/backup/*.ipf /mnt/firewalls/

My OS is Arch Linux
The bash version is 5.1.0(1)-release

If the above command does not work for you with the colon in place then you can still go back to modifying your script to remove the colon from the filename with sed or … before running your scp command

Hope the above is successful for you.


Hi @redneckmother,

Yes, I run my script via fcron.

The script is very simple.


# Runs the ipfire backup script
/var/ipfire/backup/bin/ exclude

The exclude part means that the backup is run without the logfiles. If you want the logfiles then you should replace exclude with include.

1 Like

Hey, Adolf… I suspected that’s what you’re doing… just wanted a confirmation :).