Pakfire page don't show npackages or add-ons

Just instaled IpFire, and I can’t see any update or add-on on the IpFire Pakfire page ??

[EDIT] Yes, I saw the same thing after I upgraded, and after I did a wipe and clean install. After I configured my network correctly, resolved hardware issues, and installed my previous backups I was able to click on “Refresh List” and the other fields populated. I was then able to install add-ons.

1 Like

I’m on a clean install, and don’t have any connection problem :face_with_hand_over_mouth:

ty[root@ipfire ~]# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=111 time=5.34 ms
64 bytes from icmp_seq=2 ttl=111 time=5.31 ms
64 bytes from icmp_seq=3 ttl=111 time=5.02 ms
--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 5.024/5.225/5.342/0.143 ms
[root@ipfire ~]# ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=104 time=5.36 ms
64 bytes from ( icmp_seq=2 ttl=101 time=5.11 ms
64 bytes from ( icmp_seq=3 ttl=101 time=5.49 ms
pe or paste code here

@phdemartin … can you refresh the pakfire List in your first screenshot ?

(and welcome to the community)


Press the “Save” button in the “Repository” section of Pakfire while keeping the setting to “Stable”.
Also check the Pakfire logs in Logs > System Logs then section Pakfire.

1 Like

Now it’s populating the add-ons, but no update available for now… we will see

1 Like

You did a fresh install of Core Update 162 which is the latest released version so you won’t see any updates in the Pakfire table yet. You will then have installed the latest version of any addons that you wanted. So everything will be at the latest released version.

Any updates available for your installed addons will show up when Core Update 163 is released.


I am having the same issue. I just did a clean install on a different PC, everything basically setup how the old PC was.

When I refresh, it just remains blank. When I Save Stable, it gives me a page of attempts to download from, which appears to be down.

Hi @rathouse

Welcome to the IPFire community.

I just tried a refresh on my IPFire and everything went fine. was reached and responded so it is not down now.

Maybe try again now and see if it works. If it doesn’t then that would suggest a DNS problem of some form or other.

1 Like

Still no joy here. If I go to the web site I get a 503 error:
" Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later."

I’ve tried using numerous DNS servers.
I’ve been usuig IPFire for years, and IPCop for many years before that, and never had such an issue out of the box. is not a web site so I believe that you can’t access it in a browser.

I just ran a check again on my vm IPFire and got the following log message

22:58:06 pakfire: PAKFIRE INFO: IPFire Pakfire 2.27.2-x86_64 started!
22:58:06 pakfire: DOWNLOAD STARTED: 2.27.2-x86_64/lists/server-list.db
22:58:06 pakfire: DOWNLOAD INFO: Host: (HTTPS) - File: 2.27.2-x86_64/list/server-list.db
22:58:06 pakfire: DOWNLOAD INFO: 2.27.2-x86_64/lists/server-list.db has size of 981 bytes
22:58:07 pakfire: DOWNLOAD INFO: HTTP-Status-Code: 200 - 200 OK
22:58:07 pakfire: DOWNLOAD INFO: File received. Start checking signature…
22:58:07 pakfire: DOWNLOAD INFO: Signature of server-list.db is fine.
22:58:07 pakfire: DOWNLOAD FINISHED: 2.27.2-x86_64/lists/server-list.db

It downloaded fine and came back with a 200 status code.

1 Like

Is your IPFire wui dns server page showing any errors or is everything green OK

I’ve just tried to download the file mentioned in the log
I get the complete list and PGP signature.
So the server should function, if the name can be resolved by DNS.
@rathouse : your log shows an unbound error, means you have problems in DNS resolution.

Well crikey!

I checked the ‘Domain Name System’ page, and the DNS Status was Broken. The only entries were my ISP assigned servers (reverse lookup failed).

So, I added two public DNS servers, &

Now it all works. Pakfire refreshed, AND reverse DNS lookup worked on my ISP assigned servers (even though I disabled them to use the public ones).

Also, Status is now Working. All very strange, but thanks for the help, guys.

1 Like

It’s not strange at all, it is by design.