Pakfire not updating


Just tried to update or better refresh Pakfire to no avail so far. Tried it yesterday and today, however the list of new updates stays empty

The log does not show any errors as far as I can see

OTH, I can open the page without any issues so can I open all other websites.

Any idea what might cause this?

On console, command pakfire status shows (last lines only):

Core-Version: 2.27-x86_64
Core-Update-Level: 167
Last update: 244d 6h 48m 2s ago
Last core-list update: 10m 58s ago
Last server-list update: 11m 1s ago
Last packages-list update: 11m ago
Core-Update available: yes (172)
Package-Updates available: 24
Reboot required: no

Have you tried
pakfire upgrade
on console?
Looks like the .cgi file is somewhat defunct.

1 Like

The pakfire.cgi code was changed significantly in CU170 to improve the operation, improve the error handling and ensure that you see the logs while the update is occurring.
Maybe the change from CU167 to CU172 is too large to smoothly encompass those changes.

As @bbitsch suggested try the upgrade command from the command line as the refresh showed in your messages that it knew there was a CU172 available.

After the update from CU169 to CU170 my pakfire logging and status display is much better and more consistent than before so once you have the cgi code properly updated it will run much better.

1 Like

Upgrade test from version CU167 to CU172 on a virtual machine.

:thinking: Maybe do a reboot before the ugrade? :wink:

Greetings and Happy New Year!


I used to see some updated packages on the upper right side, too. At least so far.

Will perform an update using the console and report back if succeeded or not.

Happy new year!

Happy New Year to all!

The described issue I’ve posted in my first posting above, can only be seen in browser iCabMobile on my iPadPro.

When opening the Pakfire page in Firefox (latest version) on my Windows PC I can see:

Hence it seems to be a problem with this specific browser on iPadOs only.

Thanks for reading!