Outgoing DNAT "not working"

new IPFire user here :wink:

I am trying to achieve the following:

Mail client is configured to access mail server on port 465. For a set of strange reasons independent of my I would like to keep the client’s configuration that way (I can explain why, if that matters), but the destination port should be 587 on the same mail server.

I’m trying to achieve this with the following rule:
Source: GREEN
Destination address; IP address of mail server
Protocol: TCP
Destination port: 465
External port (NAT): 587

Strangely, this results in the following display:
|1||TCP. |GREEN| | Firewall : 587
-> (ip address): 465 |

I also tried exchanging the ports, but to no avail.

What am I missing?

DNAT is to redirect traffic that terminate on one of the IPFire nics. Have you tried to connect GREEN-IPFire-IP:587 it should redirected to the configured (ip address):465.

You cannot redirect the direct way inside the green network because this not pass IPFire.

Hello Arne,
Yes I tried several combinations but to no avail. I’m not even sure a firewall is supposed to do this :wink: Not going any further on this issue now, but thanks for your input!