OpenVPN, windows client can't browse remote fileserver


I finaly got around to setting up OpenVPN on ipfire and for the most part everything went reasonably smoothly ( even OTP :slight_smile: ).

However whilst i can connect using a windows 10 computer and ping using ip and hostname I cannot browse the fileserver.

I’ve tried using explorer and NET USE on the command line and both return the error ‘windows cannot find the \\server\sharename’

Does anyone have any pointers on this ? i’m assuming it’s dns related ?

Thanks in advance for any help.


In the web user interface, /Services/OpenVPN/Advanced Server Option/ did you put the IP address of the WINS server of your network, which I guess would be you SAMBA machine?

Have you tried using an ip address instead of the name server?
e.g. \\\sharename



Thanks for the reply.

Yeah i put the WINS server address but it makes no difference.



No if i use the \servername\share or \ip\share neither work, but again thanks for the reply.


Does the remote host/server accept such connections initiated by the RoadWarrior computer?


I can ping by machines by ip and hostname ( where not blocked ) and can SSH into the (samba ) fileserver.

In ‘Advanced Server Options’ i have set the Domain, DNS and WINS information and i’ve tried it with the ‘Redirect-Gateway def1’ ticked and un-ticked.

I have also tried adding the OpenVPN Subnet (10.198.135/24) to the allowed networks in samba config.

None of these things have resolved the issue.



Is the SMB share accessible from the green network? My SAMBA share works in OpenVPN out of the box without doing anything special. Whenever I had problems, those were also present when I tried to access the shared disk from the green network.

Hi cfusco,

Yes - all shares are accessible from within the green network and all accessible when i use the Hamachi VPN that i wish to replace.

It’s a head scratcher because i’m not even sure which log file i should be looking at to try and track this down ( OpenVPN, IpFire , samba or something else )

Anhoo thanks for the help.


FYI the client config is :frowning:

#OpenVPN Client conf
dev tun
proto udp
tun-mtu 1400
remote xx.xx.xx.xx 1194
pkcs12 dummy1.p12
data-ciphers AES-256-CBC
auth SHA512
verb 3
remote-cert-tls server
verify-x509-name name
mssfix 0
auth-token-user USER
auth-token TOTP
auth-retry interact

N.B i’ve blanked out the remote IP address

I prompted the question to GPT4, have a look and let us know if you find anything. OpenVPN-SMB Troubleshooting Logs

I would first track the SMB share connection on the window machine, client side. Next I would look the logs on the samba server side, matching the time or using tail -f while attempting the connection from your windows machine.

Note, I will leave the chat publicly available for a limited time.

Did you restart samba server after saving these changes to the samba configuration file?
eg. systemctl restart smbd


The correct entry should look like