OpenVPN waiting for server

I have two clients set up with OpenVPN… One Android one Linux laptop.

Until today the Android seemed to have no connection problem.

The tablet has been an issue for while.

But, to the Android. This morning I connected and the OpenVPN client on the phone connected no problem. I then turned off the connection and went in to the meeting. Meeting was over, and need to wait for the next. So, I try to connect. Then it pops a dialog: Your connection configuration contains unsupported options…pfcs12, auth-nocache, auth-retry and offers to try to connect by ignoring them. Doing this just results in a waiting on server message.

The OpenVPN log on my server ends at the disconnect of the last session.

The .ovpn file has been modified as per this thread:

But that change was several weeks ago. And, the first connection worked.

As noted in the other thread, the laptop had issues when at one off site, but not another and I never did get that worked out.

Has something changed and I need all new keys?

I’m happy to provide any info that might help, I just don’t know what to provide. I’m on core update 185.

I had the same problem, I had the same clients :). I tried to create a new key and encountered this error:

Your android app was updated and it now considers some existing standard options as unsupported. At least that is what I suspect.

The simplest thing is to remove the options mentioned from the .ovpn file.

See this thread for other users who have experienced the problem and what they removed.from the .ovpn file


I was reading that post after I posted.

In the mean time, I tried another client app and it connected first try with the same .ovpn file.

I’ll have a go at commenting out the options.