OpenVPN Stopped Log shows it is not

I have two OpenVPN net to net connections defined. I have not yet put the credentials in the two other systems, so the Current OpenVPN server status is STOPPED.

The OpenVPN log show 10440 entries as of 10am. It keeps trying to connect and fails. Both the OpenVPN page and the Home page show both as CONNECTED

That’s really slowing the web interface down. I have to click on a link several times before it switches to the new page.

I am on Core-Update 174 Development Build: master/11f4726b

I was having some other problems so I tried the ‘Testing’ repository. When 174 came out, I switched back to stable. It didn’t update to current 174.

That’s because cu174 is a Testing Release.
See the release announcement

The openvpn server on the top of the wui page is the server for the roadwarrior connection only. Stopping that doesn’t do anything for the n2n connections.

For the n2n connection you need to uncheck the action box on the n2n connection line. That checkbox enables the n2n server for that connection and tells it to try and connect to the client. Unchecking it will stop that n2n server from trying to make the connection.


If I have understood correctly, this is the following situation



On the Wiki page: - OpenVPN Configuration

I have added:

The Net-to-Net connection works independently of the status (running|stopped) of the OpenVPN Server.

If this is wrong , someone please fix me

Best regards.

Thanks, that stopped the attempts to connect to the n-2-n connections.

The line at the top of the OpenVPN page should read OpenVPN Road Warrior Status:

That still doesn’t address the problem that both the home page and the OpenVPN page said that they were connected when they were not before I unchecked the connections.