Openvpn state after upgrade

I have core 147 and openvpn service is stopped. I went ahead and upgraded to core 149 this morning, rebooted, and saw openvpn is started. Shouldn’t the upgrade honour whatever the state of process is?
Or does the reboot starts openvpn no matter what? Thanks.

Hi pavlos,

It should normally. Beside that, there haven´t been upgrade commands for OpenVPN (openvpnctrl) in Core 148 --> https://git.ipfire.org/?p=ipfire-2.x.git;a=blob;f=config/rootfiles/core/148/update.sh;h=d4bcc45bc2b5fe02aa79c37e4898b271361d6ae1;hb=refs/heads/core148 nor in Core 149 --> https://git.ipfire.org/?p=ipfire-2.x.git;a=blob;f=config/rootfiles/core/149/update.sh;h=38f80529f48a6b78e5576e3fe53ef86c33d9af98;hb=refs/heads/core149 . So am currently not sure if this comes from the update ?

No this should not be the case if the Server has been disabled.

Best,

Erik

Thanks Erik @ummeegge for replying.
Here’s what I did:
services>openvpn, click stop openvpn server, click save
rebooted ipfire (takes about 4 min)
services>openvpn shows it running

I just tested the situation as described by @pavlos

I stopped the OpenVPN server and saved that, then rebooted and checked the OpenVPN server status. It was running. This looks like it might be a bug. I will raise it in bugzilla.

As long as you not untick the checkbox OpenVPN on RED/BLUE/ORANGE this behaviour is at least for me absolute normal. Its also independent if you save or not.

For my understanding if you want disable OpenVPN complete and not only stop “for the moment” then you have to do the before mentioned step.

See above, i dont think so.

Hi @tulpenknicker. I see what you are saying. Having one of the checkboxes ticked means that you expect a vpn connection to be available, therefore a reboot starts it if it was stopped. Unticking everything means you don’t want any vpn available, then it stays stopped.
Makes sense and confirmed by unticking all boxes and rebooting.

Agree that this is not a bug.

1 Like