OpenVPN keepalive parameter in configuration

I think there is a bug in OpenVPN config gui. After closing openvpn connection on client side, the connection still open in ipfire. I take a look in the server.conf and the keepalive parameter was missing. I go to the open vpn advanced config gui and saved advanced config. Now the parameter is in the config file and the connection closed like expected. Core Update 169 Development Build: next/8000bc0a

1 Like


thank you for reporting this.

As far as I understand, this is not an issue related to 2FA, so I moved it into a new thread to keep the original one concise.

To the best of my understanding, however, this is like it is expected to work: If keep-alive is configured, the appropriate directives will make their way to the configuration files, if not, they are not there. In the latter case, OpenVPN connections will just eventually time out - a keep-alive usage is certainly the more robust way.

Perhaps we should enable it by default? I don’t really see any disadvantages of that…

Thanks, and best regards,
Peter MĂĽller

1 Like

This is the default setting…
There is no checkbox to activate/deactivate the keepalive setting. So I expected that the setting is in the config file by default everytime.
At the end: Enable it, no disadvantages. Maybe you can add a new Checkbox (enabled by default) for this, then everyone can do whatever they want.