OpenVPN Issue Problem

how can i start my vpn ? button Start OpenVPN cant Click


Isn’t something missing from “Local VPN Hostname/IP” box?.


Got my ip there … i hide my ip for safety


What errors appear in LOG → System Logs → OpenVPN?


1 Like

This error sir

The line that says it could not find the file serverkey.pem is the reason for OpenVPN not starting.

When you created the root/host certificate set it failed. There will have been an error message at the top of the page saying something like error 256.

The reason for the error is a bug which started in Core Update 183 and is still in Core Update 184 but will be fixed in Core Update 185.

Core Update 185 should be released into Testing phase shortly.

The best option is to wait for Core Update 185 to be released.

If you need to work on OpenVPN now and can’t wait for the release of CU185 then you will need to do a fresh install of Core Update 182, restore a backup from CU182 and then create the OpenVPN root/host certificate set. After the certificate set has been created and the global settings filled in as you have done now, the server will start.

Then you can update to Core Update 184 as the bug is only related to an issue with creating the root/host certificate set.


how to fix this … i change to old version 181

now fix … how can i open port 3389 in OpenVPN IP ? this ip i want open port 3389

Can open port for OpenVPN ?

Hi @eykalzz.

If you check the OpenVPN Client settings GREEN, all traffic should be routed through the OpenVPN tunnel.

If you do not check the GREEN interface, you will have to create the routing to the RDP device by hand in the .OVPN file.

route "IP of PC" "MASK(" "OpenVPN subnet IP".

In my case, in Clients I do not have to create any rule to allow 3389, since when I create the Certificate, I mark the GREEN interface. What I do do, per FW rules, is leave the RDP port open and close all the others for OpenVPN.

I hope I’ve helped.


1 Like

still can’t connect port 3389

when i open ipchicken or whatismyip … my ip still use red ip … no show vpn ip … what problem is this ?

Hi again @eykalzz.

In Local VPN Hostname/IP: you must enter your Public IP that you have. If you have Static IP, well, if it has Dynamic, you will have to configure a DynDNS. You can do this through IPFire.

Once you have configured DynDNS, in Local VPN Hostname/IP: you must enter it.

I’ll give you the Wiki page where it explains this.

And for DynDNS:


this is my static ip … i use vpn for vps


VPN is connected … but my ip still use static … not show VPN ip …


Hi @eykalzz.

Well it should work. I have it the same except for “Redirect Gateway:” which I don’t have marked in any client.


Perhaps these routings are due to that checked box.

Try generating a certificate as you have it but without checking that box.

Nothing more to try and see.

You’ll tell us.


1 Like