Openvpn forwarding

Hi all! I am very new to ipfire, but I would really like to use it.

So far I had an iptable-based firewall (shorewall) running on a raspberry pi.
I had a green network connected to it.
I had a red network connected to an external router.
I had a masquerading setup from green to my external ip on the red interface.
I had a portforwarding rule (DNAT, UDP 1194) to my internal openvpn server running in a container on my private server.
This worked fine.
Now I tried to switch to ipfire on another raspberry pi.
green network again configured, red network (with its own IP) configured to connect to the external router.
Everything worked fine. Then I tried to implement a DNAT rule UDP 1194 to my internal openvpn server. But it get errors connecting to it. It seems, that the TLS handshake is no longer working.
Switching back to the shorewall-firewall everything works again. So I assume, I am missing something.
I also added a DNAT-rule for TCP 1194 with no luck. Is there something, I am missing in the default config? Do I need to add something else?
Thanks in advance for any help!

The issue was not with ipfire but with the setup of the ovpn server itself. The system had the old iptables gateway hardcoded as default gateway and therefore the handshake failed! My mistake!