OpenVPN client behind proxy


We have the problem that clients sitting behind a proxy server and trying to connect to the VPN server get a connection timeout.

The proxy only allows port 3128 through. Do we have to change the IPFIRE VPN.config (client) for this?

Thanks in advance.

I just saw that there is quite a bit here.
Let’s see if I can get it flying =))

To have an automatic configuration for a proxy server in the OpenVPN tunnels, add the following directives to the .ovpn file before importing it:

dhcp-option PROXY_HTTP proxy_ip 800
dhcp-option PROXY_HTTPS proxy_ip 800

where proxy_ip is the IPFire local IP where squid is running.

In alternative, you can push this directive to any client adding the following directive to /var/ipfire/ovpn/scripts/server.conf.local, assuming you have selected Additional configuration from the Web User Interface Services/OpenVPN/Advanced server options

push "dhcp-option PROXY_HTTP proxy_ip 800"
push "dhcp-option PROXY_HTTPS proxy_ip 800"

Contrary to android, you can delete the certificates (if you so desire) from inside OpenVPN connect app, in the certificates section of the app.

Do these settings also help when the proxy sits between the client and the openVPN- Server? I understand that it is meant for active proxy on the IPFIRE?