OpenVPN changing my external ip

Hi, when I connect to vpn, my existing external ip changes to the server’s external ip. How to make it not change?


in the advanced server options for OpenVPN, you need to uncheck “Redirect-Gateway def1”. This setting is responsible for routing all your traffic through the VPN.

In case you have other external servers that you want to reach through your VPN (because for example SSH access is locked to your fixed IP), you need to specify those servers’ IPs in the “Routes (one per line)” box.

Hi, unchecking "Redirect-Gateway def1 didn’t help me

Then there is an additional setting specific to the client. Create a new connection and have a look.

1 Like