Offline Installation

It’s been a while since I attempted a fresh install of IPFire and even though I’ve downloaded a full install, it’s requiring a download over the Internet. Cancel is the only other option.

Is there a way around this? I tried several different recent builds on different hardware and two different USB drives.

Hey @rolliehawk, I’m not sure what you mean by:

Could you elaborate, please?

I boot into the installer and when I choose to install it asks to download the installer image. If I click cancel the install ends. I have to hook up to an internet connection to install but I’ve not had to do that in the past.

It seems you’re describing something else.

I usually have a pc with 2 network cards, I d/l the ipfire iso, burn it into a usb and boot the pc from the usb. It installs ipfire on the pc. Then, I can run setup and configure the interfaces and other details.

1 Like

That’s exactly what’s happened for me every other time I’ve done an IPFire install in the past. That’s why I’m confused.

See this page, - Installation

there are steps how to d/l the iso, how to burn the iso into a usb stick (provides howtos if you’re on Windows or Linux), and how to run the ipfire installer, how to run setup, etc.

I’ve gone through all of that. Next time I do an install I’ll take some screenshots and share.

I switched to IPFire a couple years ago but used IPCop for years before that. Not sure what’s changed recently or what obvious step I’m missing but this is different.

If the Installer ask for a download it cannot read/detect the media. There are two possible reasons:

  1. You have an exotic drive (CD or USB) that is not supported by Linux
  2. The Media is corrupted. If you use a tool like rufus make sure it is in DD mode.

Definitely used dd but could be the thumb drives. I tried two different brands but they were pretty large. So maybe you are into something.